Hello Guest it is May 18, 2021, 01:40:19 PM

Author Topic: Mach 3 is not recognizing cutting torch  (Read 108 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 is not recognizing cutting torch
« on: February 13, 2021, 11:17:56 AM »
A friend bought a Premier Plasma CNC table with the Hypertherm Powermax 85 that apparently "just stopped working" about half way through a piece.  He was able to get part of a test cut but it crashed and since then seems to have had some trouble with Mach 3 recognizing the torch.  I've tried manually turning the torch on and off in the software but the "light" in Mach is not turning on.  When we run the program it just cruises right past the M03 and M05 but never indicates that the spindle is turned on or off.

All physical connections look good and are firmly seated. X, Y, Z appear to be accurately tuned and the Proma SD appears to be working as it should. I am doing this remotely with him using Discord, TeamViewer and our phones as needed if I need to watch two things at once. I can provide pictures and screenshots as needed and I have remote access to his computer.

I'm also not entirely sure if their should be a M08 or M07 code to activate the air or not but I'm pretty sure M03 should be just fine.  Here's the first block of code:
N0010 (Filename: TEST.tap)
N0020 (Post processor: PremierPlasma CNC Floating HeadNEW1.scpost)
N0030 (Date: 13/02/2021)
N0040 G20 (Units: Inches)
N0050 G53 G90 G40
N0060 F1
N0070 S500
N0080 (Part: TEST)
N0090 (Process: Outside Offset, LAYER1, T5: 14g)
N0100 M06 T5  (14g)
N0110 G00 X1.4630 Y2.7912 Z0.3937
N0120 G31 Z -100 F19.685
N0130 G92 Z-0.29
N0140 G00 Z0.1181
N0150 M03

X,Y look good by eye.  Z checks out using a tape measure which is good enough to get an arc.

He is using SheetCam free until he can get it running and pick up the paid version.

I can provide more specific details if I know what I'm looking for.  Thank you!

EDIT:  The PC was purchased as part of the kit and came setup.  Just wanted to note this.
« Last Edit: February 13, 2021, 11:21:22 AM by jgifford13 »

Offline TPS

*
  •  2,139 2,139
    • View Profile
Re: Mach 3 is not recognizing cutting torch
« Reply #1 on: February 14, 2021, 05:59:00 AM »
if you can post the Profile.xml we can have a look what is configured.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach 3 is not recognizing cutting torch
« Reply #2 on: February 16, 2021, 01:03:11 AM »