Hello Guest it is June 24, 2024, 05:26:20 AM

Author Topic: Mach 4 wont recognise UC100 controller  (Read 5076 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach 4 wont recognise UC100 controller
« Reply #10 on: January 22, 2021, 05:54:12 PM »
Have sent the query to Artsoft  .
Now waiting with bated breath.
Mach support supplied a remote connection link and while I was having my dinner  the problem was resolved in my absence . Came back after dinner and a notepad message told me UC100 was now connecting.
I will ask tomorrow if they can tell me what was wrong for the sake of others who may have similar probs .

Maybe they will be good enough to come here and tell us what I had done wrong. I have no objection to total honesty if it was all my fault .  I will ask them to complete the story.

I will now embark on the configuration process, but already  I  have the tool post whizzing about at silly speeds .  Probably need a bit of motor tuning but that will be tomorrow.

Thanks to all that have tried to help .  Will come back if I can get more info on what I might have done wrong

Re: Mach 4 wont recognise UC100 controller
« Reply #11 on: January 27, 2021, 07:34:22 AM »
Hi John,

I used the UC100 on my lathe when I converted to Mach4.
I'm sure you have already done all of this but just to make sure.
The uc100 plugin files (.sig and .m4pw) must be in the mach4hobby\plugins directory.
You must enable that plugin by Config->control select Plugins tab and then enable so the green check appears.
Then you can go to the Config->Plugins menu and configure the uc100.

Having said that I abandoned the uc100 because they had not done a thorough testing of the plugin on lathes and there were errors in certain operations.  I went with a pmdx411 and have been happy with its performance but it is limited in the number of inputs as is the uc100.  I still have a version 1 usb smoothstepper that runs a mill under mach3.  Have recently add another mill that runs mach4 with a Pokeys57cnc.  I and others have not been able to get the pokeys to run under usb but runs great over ethernet.  Haven't tested it on a lathe.


It seems you were correct RHT .  I am told that UC100 needed to be enabled  in the control/ config/ plugins page .
I must say  there is  a lack of info  for anyone going into Mach 4 from scratch, they just have not yet got around to a manual  which expands on the configuration, and even with experience of Mach 3  the configuration of Mach 4 is  bewildering.

And even then if UC100 does not support threading it may not serve my purpose for long.
I am looking at other options , but some members on other forums seem to have bitten a software bullet and gone to Linux CNC.  I am told that is likely to involve a steep learning curve but it seems to me that so does Mach4.

I am not looking for commercial precision  so if I can make decent short (maybe 10 mm long) threads on my TCL 125 then I would I think be satisfied .
As I have said elsewhere I dont mind spending the bucks (within reason)  on licences and a chunk of hardware as long as I am confident it is leading somewhere . Without a decent Mach 4 manual I feel that I may be troubling members of the forums unduly.

These machine are toys to me and I hope to quickly outgrow  the TCL and move  on to something more "up to the job"
My current dream is to convert a turret lathe  and would love to do one  like this , so would need  axes for LT, XT, and turret rotation , as well as spindle motor , and speed  variator ( variable speed pulley system ) But I have a way to go before I embark on that.

Maybe a prompt release of the Mach 4 manual will speed my journey   ;)
Re: Mach 4 wont recognise UC100 controller
« Reply #12 on: October 04, 2022, 01:04:44 PM »
I am wondering if this has been solved.  I just upgraded my Mach4Hobby to v2 and Mach no longer recognizes the UC100.
The UC100 files are in the plugin directory but the UC100 is not listed in Mach 4.
I reloaded the UC100 files from cncdrive but that didn't solve it.
Re: Mach 4 wont recognise UC100 controller
« Reply #13 on: October 04, 2022, 06:18:11 PM »
Never mind!  My error, it works just as bad as it did in the original mach4.  (Backlash is flaky)
Re: Mach 4 wont recognise UC100 controller
« Reply #14 on: October 04, 2022, 06:23:43 PM »
to my knowledge the UC100 does not support backlash compensation....but even if it does, backlash compensation is 'flaky' at best.
There is no solving backlash with software, not properly.

'I enjoy sex at 73.....I live at 71 so its not too far to walk.'