Hello Guest it is October 17, 2021, 05:12:25 PM

Author Topic: Cannot control the Z-axis  (Read 249 times)

0 Members and 1 Guest are viewing this topic.

Cannot control the Z-axis
« on: December 12, 2020, 08:07:35 PM »
Brand new to this and I almost broke my CNC  (3018-MX3) a couple days ago using "auto z".  It just kept going and going, breaking the bit, slamming into the sensor and nearly bending the mounting plate until I stopped it.  I tried it again and stopped it before it hit.
I went through the setup of the all of the pins as shown in the manual, etc.. and the other needed setup.  I have been reading as much as I can but I'm still not seeing the information where it says "if your Z axis won't stop this is how you set it up correctly"
I tried again using Drufel and it worked (it touched the sensor and went up).  Tried again this morning on the Drufel and it touched the sensor and went UP (that is it started going UP , not DOWN and then UP) and slammed into the z-limit and was'nt stopping until I hit the reset. (E-stop button appears to not be working)
Earlier today I read through the manuals, etc... again with Mach 3 and now its telling me "X limit switch tripped".  All switches are clear.

Please help before I break this thing.
 

Offline TPS

*
  •  2,202 2,202
    • View Profile
Re: Cannot control the Z-axis
« Reply #1 on: December 13, 2020, 05:15:00 AM »
Earlier today I read through the manuals, etc... again with Mach 3 and now its telling me "X limit switch tripped".  All switches are clear.
go to diagnostic page and check M3 Limit LED's
here can also check all other Inputs by pushing them and look at the LED's
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Cannot control the Z-axis
« Reply #2 on: December 13, 2020, 10:08:28 AM »
I have checked and only see "digitize" is lit green and at the moment "emergency" is lit red.
Last night I reinstalled the software and it seems that it is working better now.  I just cannot wrap my head around all of the Pins and Ports and what exactly are those doing...
I checked the box "Enable" (as shown in the manual) under "Output Signals" and that stopped the spindle from spinning. Unchecking that and it spins again.
Thanks for reading
Re: Cannot control the Z-axis
« Reply #3 on: December 13, 2020, 10:57:37 AM »
"Enable"


That would be "Enable 1" in the Output Signals.

Offline TPS

*
  •  2,202 2,202
    • View Profile
Re: Cannot control the Z-axis
« Reply #4 on: December 13, 2020, 01:28:31 PM »
can you pls post the Manual, Special those China machines are very different, eveb they have the same Name.
and your Profile XML i think it is Mach3Mill.xml in Mach3 Folder, but you have to rename the file bofore posting.
« Last Edit: December 13, 2020, 01:34:21 PM by TPS »
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.