Hello Guest it is September 20, 2019, 12:56:13 PM

Author Topic: Changes X0 in middle of file, licensed ver 2.52  (Read 2376 times)

0 Members and 1 Guest are viewing this topic.

Changes X0 in middle of file, licensed ver 2.52
« on: October 04, 2007, 12:11:22 PM »

I'm a newbie cutting my first file but having a little trouble.  I've been cutting the same file over and over and about half the time Mach will change X0 in the middle of cutting the file. Sometimes it cuts just fine. When the problem occurs I can press "go to z" and it seems to be going to machine coordinate X0 rather than the X0 I get off the workpiece I had the same problem with ver 2.4? and updated to ver 2.52. Any help would be appreciated.
Shepard   

Offline Graham Waterworth

*
  • *
  •  1,877 1,877
  • Yorkshire Dales, England
    • View Profile
Re: Changes X0 in middle of file, licensed ver 2.52
« Reply #1 on: October 05, 2007, 02:26:40 AM »
Hi Shepard,

if you run the program with out the machine cutting is everything OK?

Is the fault always at the same point in the program?

Graham.
Without engineers the world stops
Re: Changes X0 in middle of file, licensed ver 2.52
« Reply #2 on: October 05, 2007, 02:42:25 AM »
It will still do it if the machine is cutting air. It doesn't happen at any specific point. I've watched it happen and nothing apparent caused it.  The strange part is that whenever it happens and I stop the file and hit gotoz it doesn't go to work z it goes off to what I think is machine z which sometimes is in the complete opposite direction as work z.  Is plugged into the printer port, servos with gecko 320s.

Offline Hood

*
  •  25,850 25,850
  • Carnoustie, Scotland
    • View Profile
Re: Changes X0 in middle of file, licensed ver 2.52
« Reply #3 on: October 06, 2007, 03:31:22 PM »
When you say it will change X0 do you mean its just the X axis thats at fault?
Does the axis actually go off whilst cutting or is it if you Feed Hold then Go to Zeros that the problem occurs?

Can you post your xml file and maybe the Gcode file as well.
Hood
Re: Changes X0 in middle of file, licensed ver 2.52
« Reply #4 on: October 07, 2007, 10:58:55 AM »
It is just the x axis that seems to shift and it happens while the file is cutting.  Another interesting thing is that I can start the machine and run Mach's steps per unit utility prior to cutting the file and at 12000 spi a 4" X moves goes 4". After the problem occurs I can rerun the utility and a 4" move goes approximately 2.5 inches. The DROs notice no change when the problem occurs and act as though X0 has not shifted. Art has been helping as well but I most certainly appreciate your input.