Hello Guest it is October 24, 2021, 12:31:42 AM

Author Topic: X-Z cutting clips top of material  (Read 583 times)

0 Members and 1 Guest are viewing this topic.

X-Z cutting clips top of material
« on: October 08, 2020, 02:38:55 PM »
I posted this problem under another topic, maybe I didn't explain it very well.

On 3D parallel roughing with single line X-Z or Y-Z  movements I always get the top of the material clipped. I turned off Constant Velocity and still get the clipping. There has to be something I have setup wrong. With every other operation the router is working flawlessly and has from the beginning.

Has anyone else experienced this?

Offline Tweakie.CNC

*
  • *
  •  8,836 8,836
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: X-Z cutting clips top of material
« Reply #1 on: October 09, 2020, 01:19:55 AM »
Try setting up Safe Z (Config. menu)
KEEP SAFE !

Offline Graham Waterworth

*
  • *
  •  2,394 2,394
  • Yorkshire Dales, England
    • View Profile
Re: X-Z cutting clips top of material
« Reply #2 on: October 09, 2020, 07:38:34 PM »
We have been through this before, what CAM system are you using, 3D clearance routines can use flat 1/4" cutters, finishing profiles in most cases use ball or bull end cutters.  If you use flat cutters the lead and trailing edges of the tool dig into the work surface.

If the tool is digging into the surface then the CAM is allowing for the radius of the tool to put the contact point in the correct place.

Mach has no setting that can alter this.

A straight line in X & Z will be working from the centre line of the cutter so will overlap the edge of the cut path by the radius.
Without engineers the world stops

Offline Tweakie.CNC

*
  • *
  •  8,836 8,836
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: X-Z cutting clips top of material
« Reply #3 on: October 10, 2020, 03:38:53 AM »
Hi mjscottinnc,

I had misunderstood what you meant by 'clipping' until Graham's post explaining the situation. Please ignore my earlier post.

Tweakie.
KEEP SAFE !
Re: X-Z cutting clips top of material
« Reply #4 on: October 12, 2020, 07:20:13 AM »
We have been through this before, what CAM system are you using, 3D clearance routines can use flat 1/4" cutters, finishing profiles in most cases use ball or bull end cutters.  If you use flat cutters the lead and trailing edges of the tool dig into the work surface.

If the tool is digging into the surface then the CAM is allowing for the radius of the tool to put the contact point in the correct place.

Mach has no setting that can alter this.

A straight line in X & Z will be working from the centre line of the cutter so will overlap the edge of the cut path by the radius.

I have been able to reproduce this with two different CAM converters, Vcarve Pro and MeshCAM, and two different 3D designs. Vcarve does not show the clipping in its simulation nor does the GCode machine simulator for MeshCAM. Always the same thing on the machine; on any 2 Axis move involving a Z movement toward the top of the table (X-Z or Y-Z), the surface of the material along the axis gets clipped when the Z is plunging to the new position. What you are saying is what I have suspected from the beginning.

I specifically asked both software vendors if by default the CAM conversion for 3D roughing or parallel finishing assumes a Ball Nose tool, even though both software programs allow you to select any tool. Both say no.

The attached picture is of a part machined full thickness (3/4") PTFE, a circle slot with a ellipse island in the center. No top of material machining at all.

Offline Graham Waterworth

*
  • *
  •  2,394 2,394
  • Yorkshire Dales, England
    • View Profile
Re: X-Z cutting clips top of material
« Reply #5 on: October 12, 2020, 01:25:57 PM »
Sorry we can not help you any further, its a user issue not a Mach3/4 issue.

Without engineers the world stops
Re: X-Z cutting clips top of material
« Reply #6 on: October 12, 2020, 02:20:25 PM »
Sorry we can not help you any further, its a user issue not a Mach3/4 issue.

User issue in what way? This is exactly what I wanted to avoid. CAM provider says its a machine controller problem, machine controller vender says its a CAM problem. Clearly something is wrong. The fact that two different 3D CAM programs fail in the same way wants me to think that Mach3 might have an issue.

I performed 3D machining using Mach3 on a different machine, the only difference was a slower Z axis. No clipping.

Let’s stop deflecting and solve the problem.

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: X-Z cutting clips top of material
« Reply #7 on: October 13, 2020, 08:47:50 AM »
Sounds like the Z axis acceleration setting is too slow and the CV is rounding down the edges on the XY/Z moves. Try raising the acceleration setting for Z or slowing down the overall feedrate so that Z can keep up.

Just a thought, (;-) TP
Re: X-Z cutting clips top of material
« Reply #8 on: October 20, 2020, 06:58:45 AM »
Sounds like the Z axis acceleration setting is too slow and the CV is rounding down the edges on the XY/Z moves. Try raising the acceleration setting for Z or slowing down the overall feedrate so that Z can keep up.

Just a thought, (;-) TP

Sounds logical, I had tried slowing down the Z and the clipping got worse. I never thought about speeding up the other 2. I'll give it a try and see how it works. Thanks for the suggestion.

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: X-Z cutting clips top of material
« Reply #9 on: October 20, 2020, 11:20:22 AM »
You have to speed "Z" up not slow it down. Or either slow XY down.

(;-) TP