Hello Guest it is June 16, 2019, 03:34:46 AM

Author Topic: Mach 3 issue with very large (22 meg) g-code  (Read 3887 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 issue with very large (22 meg) g-code
« on: October 05, 2007, 04:20:40 PM »
I had an issue this morning with my mill missing steps.  When I ran a specific code it ran like dog snot.  Missed steps  sounded ugly ect.  I tried running a code I knew that worked  and it ran fine.  Went back to my other code....... crappy.   Rebooted,  re-ran.... ugly still.   

I noticed that the problem code was 22 + meg in size.   changed to peramiters and got it down to 12 meg and now its running fine.   My first though was a computer issue  so I ran the signal test in mach.   No spikes.   

Is there an issues with large g-codes?   Something I need to know about?

The computer is an AMD 2100+  with 1 gig of DDR ram.   

I run lots of large code  and would like to head this issue off now,  rather then when I need something.  I machine wax  so I know that its not a material hardness issue.  Even when running the code at 50% feedrate the motors stalled and sounded just bad!

Any Ideas?

Offline Chaoticone

*
  • *
  •  5,502 5,502
  • Precision Chaos
    • View Profile
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #1 on: October 05, 2007, 05:25:26 PM »
Might be the graphics on your PC choking. What do you use for Graphics? Is it onboard or do you have a graphics card? If so, do you have the specs? The only other thing I can think of right off is something in your file that Mach doesn't like. What did you change to get the file to half size?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #2 on: October 05, 2007, 05:30:06 PM »
the video card is an AGP ATI Radeon 7000 series 32 meg

I re wrote the toolpath with less stepover  and changed the actual part so it wasnt so high in Z and lowered the resolution of the part.  All these things added up to a G code that was half the original size

Offline Chaoticone

*
  • *
  •  5,502 5,502
  • Precision Chaos
    • View Profile
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #3 on: October 05, 2007, 06:00:28 PM »
Have you tried to turn off some of the toolpath screen features and see if it helps?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #4 on: October 05, 2007, 06:09:52 PM »
turn off....... hummm.......  I dont really use the visual toolpah screen... let me see if that does it.......

can you tell me what to turn off so I dont screw it up?
« Last Edit: October 05, 2007, 06:12:12 PM by fixittt »

Offline Chaoticone

*
  • *
  •  5,502 5,502
  • Precision Chaos
    • View Profile
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #5 on: October 05, 2007, 06:25:31 PM »
Just remember what options you have checked in config, toolpath and uncheck all of them.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #6 on: October 05, 2007, 08:19:43 PM »
unchecked them all,  and now when I load the 12 meg file  I get the watchdog has been triggered.

re ran the driver test and it looks really flat.    CPU is regestered at a 1.7   (AMD 2100 +)  AMD never could get the numbers right!

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #7 on: October 05, 2007, 08:42:34 PM »
Try turning the toolpath off via the button on the Diagnostics page. On my version its just above the reset button but could be placed elsewhere depending on version.
Hood

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 issue with very large (22 meg) g-code
« Reply #8 on: October 05, 2007, 08:46:11 PM »
Also not sure what you mean regarding AMD andnot getting  the numbers right but a 2100+ is at the correct clock when runing at 1733MHz.

Hood