Hello Guest it is February 28, 2021, 08:46:43 PM

Author Topic: Cut corners, but no loss of position  (Read 140 times)

0 Members and 1 Guest are viewing this topic.

Cut corners, but no loss of position
« on: September 30, 2020, 10:01:15 PM »
Good day folks!

New to the forums, but I've been using mach3 here and there over the years.

I recently converted a 20 year old multicam to mach3(or at least my technician did :p ).  It is running well, but I'm having a problem in the corners.

I'll be attaching photos.  Basically it seemed like this was only happening on sharp corners, but now it seems like curved corners as well.  The CNC seems to sort of over cut or skip the turn.  I do not lose position, but just not have an accurate corner. 

I recently uped the speed(IPM) of my machine, and it is running well.  But I occasionally have these missed corners.

I am running at 25k Hz, 270ipm, 5hp spindle.  I have the look ahead set to 200 right now, but I had this also at 120 lines ahead.  I've played with the acceleration/deceleration, and have it set right now at 3.

Latest version of mach3 installed.  Running through a printer port.

In the photo, you can see how the two small corners are different.  They should be the same and have a .25" radius.

And in pockets, it sometimes leaves small pieces.

Thank you, I hope I didn't write to much.

Jordan

Offline reuelt

*
  •  487 487
    • View Profile
Re: Cut corners, but no loss of position
« Reply #1 on: September 30, 2020, 11:50:44 PM »
Good day folks!

New to the forums, but I've been using mach3 here and there over the years.

I recently converted a 20 year old multicam to mach3(or at least my technician did :p ).  It is running well, but I'm having a problem in the corners.

I'll be attaching photos.  Basically it seemed like this was only happening on sharp corners, but now it seems like curved corners as well.  The CNC seems to sort of over cut or skip the turn.  I do not lose position, but just not have an accurate corner. 

I recently uped the speed(IPM) of my machine, and it is running well.  But I occasionally have these missed corners.

I am running at 25k Hz, 270ipm, 5hp spindle.  I have the look ahead set to 200 right now, but I had this also at 120 lines ahead.  I've played with the acceleration/deceleration, and have it set right now at 3.

Latest version of mach3 installed.  Running through a printer port.

In the photo, you can see how the two small corners are different.  They should be the same and have a .25" radius.

And in pockets, it sometimes leaves small pieces.

Thank you, I hope I didn't write to much.

Jordan


Try this setting in General Config
(see attached)
"the gift of God is eternal life through Jesus Christ our Lord"
Re: Cut corners, but no loss of position
« Reply #2 on: October 01, 2020, 12:06:00 AM »
Thank you!

Any number you suggest?  Or just monkey with it?

Offline reuelt

*
  •  487 487
    • View Profile
Re: Cut corners, but no loss of position
« Reply #3 on: October 01, 2020, 12:11:36 AM »
We usually want sharp 90deg corners, that is why >89 is a useful setting.
You may try other values to suit your other preference.
"the gift of God is eternal life through Jesus Christ our Lord"

Offline TPS

*
  •  1,999 1,999
    • View Profile
Re: Cut corners, but no loss of position
« Reply #4 on: October 01, 2020, 02:40:31 AM »
you can also try to run exact stop mode insteed of constant velocity.
anything is possible, just try to do it.
if you find some mistakes, in my bad bavarian english,they are yours.