Hello Guest it is May 17, 2021, 12:41:11 PM

Author Topic: M10/M11 Control  (Read 629 times)

0 Members and 1 Guest are viewing this topic.

Re: M10/M11 Control
« Reply #10 on: October 12, 2020, 05:29:41 AM »
OK. I now have my laser up and running and have mage a few cuts and etched some text without destroying my retinas.
Thanks for all of your help but I still have one small problem I need help with.
The laser is etching a line when it moves between operations and some of the sections of the text etch are missing. See pics.
I assume this is a problem with the CAM so not sure if you can help.
I use Fusion 360 with the Autodesk laser post proccessor.
In a lot of posts here I see mention of a Mach3 Laser Plugin. What is that and can I use it?
Thanks

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M10/M11 Control
« Reply #11 on: October 12, 2020, 06:25:42 AM »
Nice work, you have made great progress.

The unwanted lines are clearly the laser not turning OFF correctly but the missing lines are strange. Perhaps you could observe the engraving to determine if the laser is turning OFF too early or turning ON too late ?

It could be related to your CAD/CAM but if you post your problem Gcode I will test it here and that will prove one way or the other.

The Mach3 Impact / Laser plugin only operates using the Parallel Port and will not work when using the ESS.

Tweakie.
KEEP SAFE !
Re: M10/M11 Control
« Reply #12 on: October 12, 2020, 06:34:38 AM »
Thanks Tweakie.
Have attached two files. One for the cutting and one for the text.
The problem doesn't seem obvious in the code but then I am not an expert
Thanks again

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: M10/M11 Control
« Reply #13 on: October 12, 2020, 07:10:04 AM »
Your Gcode files operate correctly so it's something related to your laser switching. Is it switching too early or too late ?

Tweakie.
KEEP SAFE !
Re: M10/M11 Control
« Reply #14 on: October 12, 2020, 07:43:41 AM »
seems to be switching too early and there are no lines between each letter