Hello Guest it is February 27, 2021, 08:18:32 AM

Author Topic: Sharing home limit switches not working  (Read 152 times)

0 Members and 1 Guest are viewing this topic.

Sharing home limit switches not working
« on: September 08, 2020, 07:11:34 AM »
I have everything working except homing. I am sharing home and limit switch.
If I turn off limit switch it homes properly. As soon as I enable the sharing home/limit it throws limit switch error.
I tried debouncing to no prevail.
I put an arduino between the prox switch and input to the bob so I know no debounce is happening. I did this for testing.
It is still causing the issue. I have home switch and two limit switches on the machine but I have a retrofit of a commercial machine with only one prox switch per axis, so I need this working.

Would going to Mach4 fix this issue? Mach 3 is not ignoring the limit switch while homing. Is there anything I need to do besides sharing the pins in "ports and pins"?

I am new to mach3. I come from the other side......
« Last Edit: September 08, 2020, 07:14:22 AM by bevins »

Offline Graham Waterworth

*
  • *
  •  2,274 2,274
  • Yorkshire Dales, England
    • View Profile
Re: Sharing home limit switches not working
« Reply #1 on: September 08, 2020, 10:36:28 AM »
 Try setting the Home off in homing and limits or go to section 4.5.4 of the Mach3 installation guide.
Without engineers the world stops
Re: Sharing home limit switches not working
« Reply #2 on: September 08, 2020, 07:17:08 PM »
Try setting the Home off in homing and limits or go to section 4.5.4 of the Mach3 installation guide.

I've read that. I've done that. I see everytime someone has an issue similar to this the responses are check the debounce or noise on 5v. Well, its not the noise threshold as i am using 24v and it is prox switches. I messed with debounce and it doesnt fix the issue. I even programmed an arduino to simulate the switches and it still does it. It's not the installation. It's mach3 not doing what it is suppose to do or I have a setting somewhere wrong that pertains to this. Ive done over 25 retrofits, mostly with linuxcnc, so I am not a newbie at this.

I guess I will see if Mach4 eleviates this. At least the log will tell me what its doing.
Re: Sharing home limit switches not working
« Reply #3 on: September 09, 2020, 06:57:11 AM »
I regulated the issue. Was on my part not having the ESS homing config done. IT is working now.
Sorry for the bother, I don't normally use Mach3 and I was getting frustrated.

Thanks,

Bob