Hello Guest it is April 13, 2021, 11:54:15 AM

Author Topic: Losing Z reference with G Code generated from Fusion360  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Re: Losing Z reference with G Code generated from Fusion360
« Reply #10 on: August 26, 2020, 11:41:35 AM »
The more I read, the more I suspect that G43 is the problem.
Re: Losing Z reference with G Code generated from Fusion360
« Reply #11 on: August 26, 2020, 03:16:33 PM »
so ....change by notepad and test
Re: Losing Z reference with G Code generated from Fusion360
« Reply #12 on: August 26, 2020, 03:19:30 PM »
Doing so, just trying to find the time to do it.
Re: Losing Z reference with G Code generated from Fusion360
« Reply #13 on: August 26, 2020, 04:31:50 PM »
Nope didn't fix it, tried it with a different job, still losing Z with code generated by Fusion 360
Re: Losing Z reference with G Code generated from Fusion360
« Reply #14 on: August 27, 2020, 06:42:52 AM »
The Autodesk rep said it looks like a post problem and gave the issue to someone else.......

Disappointing.
Re: Losing Z reference with G Code generated from Fusion360
« Reply #15 on: August 31, 2020, 07:27:40 AM »
This from the autodesk support folks:

"delete this in the NC code in all spots where it shows up and carefully take a trial in the machine.

G20
G28 G91 Z0.
G90"

Did so and the problem appears to have ceased, which makes me wonder why those codes ended up producing this issue.

Offline thosj

*
  •  432 432
    • View Profile
Re: Losing Z reference with G Code generated from Fusion360
« Reply #16 on: August 31, 2020, 11:44:07 AM »
Read this and see if you can glean any info regarding your machine and G28. G28 can be a weird one!!

https://www.mmsonline.com/columns/g28-versus-g53

Tom