Hello Guest it is October 21, 2021, 02:43:22 PM

Author Topic: Mach 3 stopping Ref All Home after Y (not moving A axis to alignment switch)  (Read 366 times)

0 Members and 1 Guest are viewing this topic.

I have read and tried many many different codes and operations throughout posts. To my inability to be successful I am reaching out for HELP!
Let me first say that when I move my (WorkBee CNC) using Mach 3 and set the X,Y & Z to my work area zero. I have no issues running an imported G Code. All motion of axis machining is correct.

When I first open Mach 3 and click on REF ALL HOME. The Z moves until switch is made, then moves off switch. The Y moves until switch is made then moves off switch.....At this point everything stops and Status: remains blank. It is not until I place a jumper between the installed switch for A, or use the arrow key to jog to make A axis switch, that the unit moves on to complete the zero for X.

In Homing/Limits = Auto Zero is checked for X,Y,Z,A
In Slave Axis Selection = X axis - None, Y axis - A axis, Z axis - none

In General Config - Home Slave with Master Axis is not checked (tried both ways - if it is checked then it never looks for the A axis switch made and moves on

Just as others I am trying to get this to work to ensure accurate alignment. At the moment I turn the system off and measure each side, manually rotating the slave of Y.

Current script in REF ALL HOME:
DoButton( 24 ) 'Ref Z
DoButton( 23 ) 'Ref Y
DoButton( 22 ) 'Ref X
DoButton( 25) ' Ref A



DoOEMButton(133) 'Zero X encoder
DoOEMButton(134) 'Zero Y encoder
DoOEMButton(135) 'Zero Z encoder

Online Graham Waterworth

*
  • *
  •  2,393 2,393
  • Yorkshire Dales, England
    • View Profile
Do you have Softlimits turned on?
Without engineers the world stops
Settings in pic