Hello Guest it is May 12, 2021, 08:30:35 PM

Author Topic: [ESS] Z axis issues  (Read 634 times)

0 Members and 1 Guest are viewing this topic.

[ESS] Z axis issues
« on: August 05, 2020, 03:52:15 AM »
Hi,
Im using selfmade 3,6m x 1,7m plasma table, using Ethernet Smoothstepper with cnctechnics.de breakout board (https://shop.cnc-technics.de/product_info.php?info=p16_breakoutboard-fuer-ess-smoothstepper.html), steppers droven by Leadshine's EM806s, and a Hypertherm 45XP Plasma.
Mach4 devbuild 4.2.0.4517 / Warp9 ESS plugin v261
Copied and slightly modified plasma profile, with ess HC screenset (v04).
I've had my setup running with Mach3, and recently decided to migrate to Mach4.
So far it have been successful, although not completely functional.
Example gcode:
Code: [Select]
%
N0010 (Filename: M4WEWX1_HOR_NOG9.tap)
N0020 (Post processor: ESS Up Down Mach4 v002_G90less.scpost)
N0030 (Date: 04/08/2020)
N0040 G21 (Units: Metric)
N0050 G53 G90 G91.1 G40
N0060 G64 M8 (Constant Velocity Mode - normally used with Plasma)
N0070 m2020 (HC_Z_MAX_VALUE=100)
N0080 m2020 (HC_Z_MIN_VALUE=-50)
N0090 m2020 (HC_Z_VELOCITY_UP_SPEED_PERCENTAGE=20)
N0100 m2020 (HC_Z_VELOCITY_DOWN_SPEED_PERCENTAGE=20)
N0110 G4 P0.01
N0120 (Part: AFTER 0310_0327 126p PrĂ³g wewn. LEiPR)
N0130 (Operation: Outside Offset, 0, T1: Plasma, 1.524 mm kerf)
N0140 G00 X28.8304 Y46.9076
N0150 (>>>Probe/Ref<<<)
N0160 G31.0 Z-70  F500.0
N0170 G00 Z4.5000
N0180 m2020 (HC_WORK_Z_ZEROED=1)
N0190 G4 P0.1
N0200 G00 Z3.5000
N0210 G4 P0.001
N0220 M62P1 (>>>Torch ON<<<)
N0230 Z3.4000
N0240 G01 X35.7682 Z3.5000 F3200.0
N0250 X38.8304 F2800.0
N0260 X50.7682
N0270 Y36.9742
N0280 G03 X51.2492 Y36.2659 I0.7620 J0.0000
N0290 G01 X65.1922 Y30.7347
N0300 X81.3293 Y24.3330 F4000.0
N0310 X95.2723 Y18.8017 F2800.0
N0320 G03 X96.2340 Y19.1677 I0.2810 J0.7083
N0330 G01 X101.3940 Y29.4300
N0340 X111.0205 Y29.4093
N0350 Y11.1696
N0360 G03 X111.7825 Y10.4076 I0.7620 J0.0000
N0370 G01 X133.7825
N0380 G03 X134.5445 Y11.1696 I0.0000 J0.7620
N0390 G01 Y29.4076
N0400 X148.7825
N0410 G03 X149.5445 Y30.1655 I0.0000 J0.7620
N0420 G01 X149.6248 Y45.1653
N0430 X154.4288 Y942.2019 F4000.0
N0440 G03 X154.3947 Y942.4313 I-0.7620 J0.0041
N0450 G01 X135.1613 Y1004.5630
N0460 X130.7256 Y1018.8921 F2800.0
N0470 G03 X129.7990 Y1019.4024 I-0.7279 J-0.2253
N0480 G01 X115.3181 Y1015.4903
N0490 X58.5038 Y1000.1416 F4000.0
N0500 X44.0229 Y996.2295 F2800.0
N0510 G03 X43.4597 Y995.4962 I0.1987 J-0.7356
N0520 G01 X43.4225 Y983.2584
N0530 X27.0865
N0540 G03 X26.3246 Y982.5108 I0.0000 J-0.7620
N0550 G01 X26.0400 Y967.5135
N0560 X13.0685 Y284.1841 F4000.0
N0570 X13.0726 Y284.0895
N0580 X37.5470 Y52.5618
N0590 X38.0726 Y47.5895 F3200.0
N0600 X39.1238 Y37.6449
N0610 M63P1 (<<<Torch OFF>>>)
N0610 G4 P1
N0620 G00 Z50.0000
N0621 G4 P1
N0630 G00 X0.0000 Y0.0000
N0640 M9
N0650 M30
%

Sometimes it stops at line N0190, the cycle time timer running, but it does completely nothing. I have to stop/disable, then cycle start again, and the code executes further like nothing happened. Tried mixing in some G4 P# delays but it didnt help.
But 90% of the time, after cutting the part, torch disables, and the move to 0,0 begins, the line 62 G00 Z50.0000 makes my axis go slightly down (while it should go up), just above/at the material, while Z DRO says my Z is at 50.0000. Outside of this scenario, commanding Z moves brings expected results. This forces me to cut maximum one part per program, and to manually probe Z after cut, because otherwise Z position gets mistaken.
Calling for help wherever I can, cause I really appreciate the performance of Mach4 on my machine, and would love to completely shift and forget about Mach3.

Anybody got ideas/suggestions? Also I checked if my Y stepper driver ain't stalling while on the goto0 move, but it's not the case.
« Last Edit: August 05, 2020, 03:56:36 AM by r3sist »
Re: [ESS] Z axis issues
« Reply #1 on: August 11, 2020, 11:15:08 PM »
why you use G53 on line 50--there no mining use G53 without moving G53
but you don't have origin reference like G54,G55...you also not use the G43 H...( high compensation)
so maybe you cant move in Z,
G4 in my its 1/1000 sec so write 0.001 its seems or nothing or error
thanks
yaakov
 
Re: [ESS] Z axis issues
« Reply #2 on: August 21, 2020, 07:51:16 AM »
Isnt G53 used to set absolute coordinates? Correct me if im wrong. To be clear, im not milling, im using a plasma torch.
I dont really need work/tool offsets, earlier I was working on machine coordinates only and had no issues.(mach3)
The G4 0.001 is generated by postpro, i guess its a delay to let the custom m2020 macro to execute properly.
Changing it to G4 P1 (so 1 second) made no difference in execution.
The thing is, like one out of 10 times, everything runs correctly as it should, then randomly malfunctions.
I also tried lowering plugin frequency (although im sure my pc can handle the default 40, no out of data errors) assuming something is missed between issuing the commands but it doesnt affect it at all.
Im still trying to figure it out without success, hope someone has and idea of the cause at least.
Re: [ESS] Z axis issues
« Reply #3 on: August 21, 2020, 10:16:53 AM »
Send you a PM message
Re: [ESS] Z axis issues
« Reply #4 on: November 12, 2020, 06:28:36 PM »
Did you ever find a resolution for this I have the same issue
Re: [ESS] Z axis issues
« Reply #5 on: November 13, 2020, 01:49:39 AM »
cnckr PMmed me this:
Quote
Hej from Denmark
you are catced in a trap
P1 and p0.001 is both 1 ms and mach4 can only work with delay bigger than 1 ms
like p0.0011 or p0.0010000000001.
P11 will work, but is 11 ms
reg cnckr Knud
but adjusting the delay to be appropiate in miliseconds for mach didn't prevent it from getting stuck mid file.

The problem still persists and the fact that more of u guys show with the same issue just tells me that its a problem on the mach4 current build we all use / the ess plugin.
I've reinstalled whole mach, set up the most basic screenset/profile to avoid messing ********* up multiple times, and in the end, it may work for a few tables, then dont work for the rest of the day. And the next day wont work at all :)

So lets hope the clever ones will address this soon, cause as i said besides that, mach4 with ess looks sexy now, and thats the only problem left with it (at least for me).
Re: [ESS] Z axis issues
« Reply #6 on: November 16, 2020, 06:14:37 PM »
I too, have this same issue with the G04 P0.********* stalling intermittently.   This stall only occurs after the m2020(HC_WORK_Z_ZEROED=1) and it stalls about 50% of the time (may work one time and then stall the next time).  I am not sure if this is a Mach4 or a ESS problem.  This same issue has been reported to Warp9 and they have come up with a Temp work around.  See Warp9td.com forum and search for "G04 P0.10 stall."   The 'look ahead' value also seams to be involved with this problem, also.
I hope that Mach4/Warp9 guys can get to root cause and come up with a solution soon.

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: [ESS] Z axis issues
« Reply #7 on: November 16, 2020, 09:19:41 PM »
Here is a possible fix until the issue is found, I have only tried it on a simple program but it seems to work.

Copy the macro file into the macro folder for your profile.

Then do a replace of all the G4 or G04's in the file with M104 and make sure the P value is in milliseconds 1000 per second.

You try it at your own risk.
Without engineers the world stops
Re: [ESS] Z axis issues
« Reply #8 on: November 17, 2020, 02:14:12 AM »
Yeah I also stumbled upon this workaround, but Milisleep causes everything to stop, and while there are multiple custom macro callouts, there are a lot pauses during a job. At work i cannot allow this because the whole process runs too slow, although its a better fix than nothing, but far from satisfying.
I read somewhere it had some connection to the gcode parser and the lookahead buffer. Something just goes wrong during custom macros over time.
And for plasma application with ESS, its crucial to use them to have the Z functionality it offers.

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: [ESS] Z axis issues
« Reply #9 on: November 17, 2020, 10:17:53 AM »
I am glad I didn't waste my time working on a fix.
Without engineers the world stops