Hello Guest it is November 14, 2019, 11:01:06 AM

Author Topic: Unable to config Mach3 with Cambell breakout board  (Read 3753 times)

0 Members and 1 Guest are viewing this topic.

Unable to config Mach3 with Cambell breakout board
« on: September 30, 2007, 12:14:48 AM »
Hi all,
Any help appreciated.  I have up and running fine a BP clone, with Campbell Breakout board and Gecko 201's.  But...the X and Y axes are reversed even thought the wiring is correct.  When I correct that by either changing them in Mach3 or by swapping the wires, then the hot keys for jogging X and Y are reversed and the Mach three will let me change the designated hot keys in the software, but the changes are somehow not transmitted and the hot keys remain reversed.  Even if I start from the other direction and correct the hot keys first, then the X and Y remain reversed when I run Mach3's sample programs, with the Y axis moving when a x move is commanded in the program. I have repeatedly re installed the xml file from campbell, and even re installed the latest revision of Mach 3.

Thanks in advance for any help, what am I missing?

Harvey Price

Re: Unable to config Mach3 with Cambell breakout board
« Reply #1 on: September 30, 2007, 04:06:23 PM »
My BAD!!

I was trying to change the hotkeys in the ports and pins, inputs screen.  You can change the hotkey numbers on that screen but they have no effect. They have to be changed in the Hotkey module further down the Config list. The system is running great now and I am cutting test parts.

Harvey Price

Offline Chaoticone

*
  • *
  •  5,628 5,628
  • Precision Chaos
    • View Profile
Re: Unable to config Mach3 with Cambell breakout board
« Reply #2 on: September 30, 2007, 08:38:57 PM »
 :)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!