Hello Guest it is April 17, 2021, 10:09:57 AM

Author Topic: Pocket Cut Issue.  (Read 407 times)

0 Members and 1 Guest are viewing this topic.

Pocket Cut Issue.
« on: June 15, 2020, 03:48:25 AM »
Hi there I am running Mach3 win 7. I have not had this issue before I have attached an Image of a pocket cut.
Im using a 16mm endmill for the job. I have added a ATC and using offsets for the tool length.
I checked measurements on x and y they are correct.Its happening on the end of the cut. I changed tools to see if that was the issue.
 Any ideas are greatly appreciated. regards Stuart

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Pocket Cut Issue.
« Reply #1 on: June 15, 2020, 04:06:41 AM »
Hi Stuart,

It looks very much to me that you have lost position (perhaps due to tool loading).
Did the tool return exactly to the original datum point at the end of the run or was there an error ?

Tweakie.
KEEP SAFE !
Re: Pocket Cut Issue.
« Reply #2 on: June 15, 2020, 04:52:34 AM »
Tomorrow I will check to see where it is finishing, the issue is also happening with no tool change. regards Stuart
Re: Pocket Cut Issue.
« Reply #3 on: June 15, 2020, 05:06:55 AM »
I just checked and x was out .0079 mm which wouldnt be causing the issue would it?
The other issue is when I restart Mach3 it continuall give me the abnormal condition error, and I have to refer all home to remove the error.

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Pocket Cut Issue.
« Reply #4 on: June 15, 2020, 05:35:49 AM »
The 0.0079 mm error would not be causing the issue.

Are you using G41/G42 cutter radius compensation in your Gcode ?

KEEP SAFE !
Re: Pocket Cut Issue.
« Reply #5 on: June 15, 2020, 07:25:13 AM »
No I am not this code is written in vetric aspire.
 I am a newbie where the code is concerned Regards Stuart

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Pocket Cut Issue.
« Reply #6 on: June 15, 2020, 08:14:28 AM »
Assuming you are using the correct post processor then Vectric toolpaths are 100%.

My only conclusion is that somehow you are loosing position (lost steps) and that is the cause of the problem. Have you had any other instances of positional error or incorrect tool path ?
KEEP SAFE !
Re: Pocket Cut Issue.
« Reply #7 on: June 16, 2020, 03:52:05 AM »
I think it may be in the atc gcode, as I did a clean install without the atc and no issue. regards Stuart

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Pocket Cut Issue.
« Reply #8 on: June 16, 2020, 03:58:32 AM »
I am pleased that you have found the problem.

Tweakie.
KEEP SAFE !
Re: Pocket Cut Issue.
« Reply #9 on: June 18, 2020, 04:54:44 AM »
Hi there I am a newbie to all this I have uploaded the xml file and the gcode. Is there any way to see if the issue is in here? all help appreciated. regards Stuart