Hello Guest it is November 17, 2019, 07:34:13 AM

Author Topic: Constant Velocity Changed Recently  (Read 3640 times)

0 Members and 1 Guest are viewing this topic.

Constant Velocity Changed Recently
« on: September 21, 2007, 02:27:00 PM »
Brian,

Noticed that CV has changed in one of the last few releases.
My CV was running smooth thru Rel 2.42 then I noticed it started acting like it was in Exact Stop mode.

Sorry I didn't catch it until Rel 2.48 so don't know which release between these 2 started the problem.
I've reinstalled the older release and it works fine.  I'm guessing a modification around the first part of September is where it started.

I've been running steppers on my router without any problems for the past 2 years.
Let me know if you need more information.

Thanks,
Tom

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Constant Velocity Changed Recently
« Reply #1 on: September 22, 2007, 04:22:13 AM »
Hi - R2.48 had CV modified on the 5th Sep. I suspect you'll need to re-tweak your CV tolerances as it sounds like your angles that were being blended are now being "exact stopped" - see http://www.artsoftcontrols.com/forum/index.php?topic=4113.0
Hope this helps until Brian can give you a fuller answer.

vmax549

*
Re: Constant Velocity Changed Recently
« Reply #2 on: September 22, 2007, 10:47:44 AM »
Tom creat a test file that shows up the jerks you are seeing.  First turn off the CV and run the file. Then turn on the CV and see if it is different. Make sure that the file is not turning on and off the CV for you (;-)

(;-) TP
Re: Constant Velocity Changed Recently
« Reply #3 on: September 22, 2007, 02:07:13 PM »
Thanks for the information guys.

I'll install the latest codes then start tweaking the CV and see if I can get it to smooth out.
Will reply with my results but may be a little later, working a contest this weekend.

Tom
Re: Constant Velocity Changed Recently
« Reply #4 on: September 24, 2007, 10:21:55 AM »
OK, I'm back in business. 

For a guy that reads the Yahoo and Online Forum daily I sure skimmed over the answer to this.
I turned off (Stop CV on angles >) which smoothed out my run again.  For some reason I felt uncomfortable turning this off.

To verify sharp angles were not being rounded I installed my plotting attachment and ran a test object with sharp angles and long splines.
Ran this plot over itself 5 times with no deviation and all 90 deg corners looked square (used a magnifying glass).
Plot was run at 50 ipm so routing at 35 ipm should be fine.

Thanks TP and Stirling for your advice.  I'm afraid I was asleep at the keyboard on this one.

Regards,
Tom
Re: Constant Velocity Changed Recently
« Reply #5 on: September 25, 2007, 08:59:33 AM »
Sorry I did not post on this... My ISP was having trouble and I was down for 4 days :(

Happy to hear that you got it fixed !

Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Constant Velocity Changed Recently
« Reply #6 on: September 26, 2007, 02:09:32 PM »
could someone explain the constant velocity settings to me.   Mine is set at 180  (default)   and I am wondering if there is tweaking that could smooth out my mill.

Thanks.
Robert
Re: Constant Velocity Changed Recently
« Reply #7 on: September 27, 2007, 10:22:51 AM »
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com