Hello Guest it is July 12, 2020, 12:09:40 AM

Author Topic: Mach3 freezes afterloading g-code/toolpath graphics  (Read 312 times)

0 Members and 1 Guest are viewing this topic.

Mach3 freezes afterloading g-code/toolpath graphics
« on: February 26, 2020, 05:27:54 PM »
hey guys, im using basic old school style lathe screensets in mach3, with cs/labs on a PC with windows 7 pro 64-bit.
About 70% of the time when i load G-code it freezes as soon as tool path graphics is finished loading, and its bar graph pop up window goes away. I get a "not responding" error from windows and Mach3 completely crashes, have to restart.
The 30% of the time it does load, system runs great though.
Any ideas or pointers?

Offline TPS

*
  •  1,608 1,608
    • View Profile
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #1 on: February 27, 2020, 04:00:56 AM »
witch Version of Mach3 are you using?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #2 on: February 27, 2020, 04:09:44 PM »
Version R3.043.066

Offline TPS

*
  •  1,608 1,608
    • View Profile
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #3 on: February 28, 2020, 02:44:37 AM »
« Last Edit: February 28, 2020, 02:46:36 AM by TPS »
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #4 on: February 28, 2020, 09:05:13 AM »
thank you, ill give it a shot and kee pyou posted
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #5 on: February 28, 2020, 05:37:29 PM »
Well, i gave it a go, but no such luck. Still freezes.
I did notice 1 additional thing though. It only does it if im on a screen that displays tool graphics (auto or manual)
If i do it from the opening screen works everytime without flaws.
Any other ideas? im using the basic 1024.lset screens

Offline TPS

*
  •  1,608 1,608
    • View Profile
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #6 on: February 29, 2020, 02:58:59 AM »
can you post your gcode for a test?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #7 on: March 25, 2020, 09:17:53 AM »
Here is the G-code, machine finally gave me an error msg "art code 709" no description. Rebooted system, no error codes but it would still freeze up when graphics are near loaded. As a wild idea i reloaded the 1024.lset file and it started loading without freezing, but then it did something else odd. on the line of code "X.585" it repeats it for a large amount of times. attached pics. any words of advise?

Offline TPS

*
  •  1,608 1,608
    • View Profile
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #8 on: March 25, 2020, 09:47:06 AM »
pls post the complete file.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 freezes afterloading g-code/toolpath graphics
« Reply #9 on: March 27, 2020, 03:08:43 PM »
Please see attached.