Hello Guest it is April 21, 2021, 01:35:30 PM

Author Topic: Mach 3 problems with axis  (Read 397 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 problems with axis
« on: February 05, 2020, 12:14:28 PM »
Greetings
Yesterday after adjusting the steps per unit for our CNC 3 axis router, Mach 3 stopped movingt the X axis.
other symptoms include

  • Inability to set zeroes on any axis
    after reloading a gcode, the path generated on the windows only shows displacement on Y and Z,
    Cannot jog X, however Y and Z respond normally.
    Cannot callibrate X axis
    after inverting the Motor outputs between X and Y, the jogging isue also inverted
The router builder suggested reinstalling the software, but this did not solve the problem.

I will thank any suggestions that might point me to the solution of this problem.

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 problems with axis
« Reply #1 on: February 06, 2020, 02:01:34 AM »
Mach3 saves your previous settings (contained in the xmlbackups folder).

Within Mach3 select Operator / Restore Settings... and choose a backup from a date before you altered your settings and caused the problem.

Tweakie.
KEEP SAFE !
Re: Mach 3 problems with axis
« Reply #2 on: February 06, 2020, 01:33:18 PM »
Mach3 saves your previous settings (contained in the xmlbackups folder).

Within Mach3 select Operator / Restore Settings... and choose a backup from a date before you altered your settings and caused the problem.

Tweakie.

Will take this into consideration next time, however the many attempts made to fix the issue left me with a backup in teh realm of the failed configuration, I was able to get a backup xml from the people that built the router, however with this configuration, any curve will translate on the software moving the spindle in a complete circle. Unless I raster the path along an axis
Re: Mach 3 problems with axis
« Reply #3 on: February 06, 2020, 09:06:50 PM »
Are you unintentionally reading the axis dro's with the software in "machine Coordinates" mode?
Re: Mach 3 problems with axis
« Reply #4 on: February 07, 2020, 09:15:01 AM »
I sincereley do not knoe, I have only been using mach3 for about 6 months and I did not configure it beforehand, and had only been using it with what the previous user left me, according to our software provider, the previous guy did  alter the xml, but I have not pinpointed what he changed.

Thank you for your help and support.

Offline Tweakie.CNC

*
  • *
  •  8,696 8,696
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 problems with axis
« Reply #5 on: February 07, 2020, 09:55:30 AM »
Quote
however with this configuration, any curve will translate on the software moving the spindle in a complete circle.

Change the IJ Mode in Config / General Config to eliminate the 'crop circles'.

Tweakie.
KEEP SAFE !