Hello Guest it is June 16, 2021, 12:25:49 PM

Author Topic: wierd thing with motor movements  (Read 465 times)

0 Members and 1 Guest are viewing this topic.

wierd thing with motor movements
« on: January 18, 2020, 10:42:34 PM »
So I just got one new CNC Mach3 USB controller and 4 new drivers.  I got the DM542 drivers because my old once where making the stepper really noisy.  Anyway on to the weird thing.  If run a G-code like G0x100.  The x moves across to 100mm but the weird thing is sometimes another counter in Mach3 like Y or Z registers either 0.0050mm or -0.0050mm.  But the z/Y never moves.  Also when I say G0x0 the x goes back to 0 but it usually also registers 0.0050 or -0.0050. If I then say the command again to G0x0, nothing happens.

Any ideas ???
Re: wierd thing with motor movements
« Reply #1 on: January 18, 2020, 11:16:24 PM »
just adding another comment.  I just tried this again with only the usb cnc card on.  The motors and drivers were not on.

It did the same thing.  really wierd

Offline Tweakie.CNC

*
  • *
  •  8,727 8,727
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: wierd thing with motor movements
« Reply #2 on: January 19, 2020, 01:47:37 AM »
It's not really that weird.

With your 'steps per unit' setup 0.0050 is your step size and Mach3 will not attempt to make a movement which is smaller than your step size. Essentially 0.0000 and <0.0050 is the same dimension as far as your machine is concerned and that is the way Mach3 is interpreting it.

Tweakie.
KEEP SAFE !
Re: wierd thing with motor movements
« Reply #3 on: January 19, 2020, 03:33:31 AM »
I understand.  But how does running the command g0x100 cause a different axis to say its moved .0050. 

Offline Tweakie.CNC

*
  • *
  •  8,727 8,727
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: wierd thing with motor movements
« Reply #4 on: January 19, 2020, 03:39:28 AM »
I don't know the answer to that one  :'(
Perhaps it's one of the mysteries of Mach3  :)

Tweakie.
KEEP SAFE !
Re: wierd thing with motor movements
« Reply #5 on: January 19, 2020, 03:46:27 AM »
The problem is .0050 is exactly one step on my machine.  So if it makes that mistake a bunch of time my part will be ruined.  I put a ticket in with them.   

Offline Tweakie.CNC

*
  • *
  •  8,727 8,727
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: wierd thing with motor movements
« Reply #6 on: January 19, 2020, 03:51:30 AM »
The 0.0050 is not really an error (although it appears to be) and it will not be cumulative so you have no worries about your parts being spoiled.

I would be interested to hear what the support team have to say about the issue so please report back when you have an answer.

Tweakie.
KEEP SAFE !
Re: wierd thing with motor movements
« Reply #7 on: January 19, 2020, 09:12:33 AM »
After a little more testing this morning, I decided to tell the settings inside mach3 that I was using 1/16 steps vs 1/8 steps.  An lo and behold now when I run the machine it moves the same axis weird by 0.0025 vs 0.0050.  There must be a bug in Mach3

Offline Tweakie.CNC

*
  • *
  •  8,727 8,727
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: wierd thing with motor movements
« Reply #8 on: January 19, 2020, 09:53:33 AM »
Quote
There must be a bug in Mach3

 ;D
KEEP SAFE !