Hello Guest it is November 30, 2021, 08:07:19 AM

Author Topic: Mach3 hotkeys for Jogging stopped working.  (Read 289 times)

0 Members and 1 Guest are viewing this topic.

Mach3 hotkeys for Jogging stopped working.
« on: January 12, 2020, 11:27:24 AM »
Hello, first post- I built my own Workbee with a 1.5KW spindle and VFD, and a 4 axis 425in-oz stepper and driver kit from stepper online.

 It runs Mach3 on a Win-7 PC connected to a smoothstepper and a 5axis break-out board plus a C80 expansion board. I programmed the arrow keys on a wireless keyboard to jog the machine and it worked great. It has since stopped working and all attempts to restore it have failed, tried re-programming hot keys (they are recognized by mach3). Tried different keyboards. tried re-installing Mach3. The other keys and functions work on the keyboard, including the Home hotkey, tab to bring up the jogging panel, the machine jogs fine from the jog panel, and the arrow keys work in menu's etc.

 I'm not certain but it may have quit after i installed the drivers for a RS485 -USB adapter to control the VFD & spindle. there was an error about a driver during that install, i don't remember the details. do i need to re-install a generic keyboard driver or what other suggestions do you have? 

Thanks in advance