Hello Guest it is April 20, 2021, 12:51:31 AM

Author Topic: Problems with 75 MHz settings  (Read 3372 times)

0 Members and 1 Guest are viewing this topic.

Problems with 75 MHz settings
« on: September 16, 2007, 05:33:54 AM »
Hi all,

I used the 45 MHz setting for a while and had no problem. With the newest version I changed to 75 MHz to get a higher resolution on my servos. Now I have a problem when I restart my computer. When I want to move the axis all the servo controller go in error. You also can hear it, the servos make a different noise.
I can only solve the problem when I set to 45 MHz, restart MAch change it to 75 MHz and restart Mach again. After that procedure I can work with no other problems,.., till I restart the Pc.  ???
I already reinstalled MAch but nothing happend. Any ideas??

Thanks

Dirk

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: Problems with 75 MHz settings
« Reply #1 on: September 16, 2007, 06:21:23 AM »
When you set it to 75, what pulse rate are you getting on the diagnostics screen? Check it with a fresh start, (when it is giving trouble) and after a start at 45.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Problems with 75 MHz settings
« Reply #2 on: September 16, 2007, 06:31:53 AM »
Hi Brett,

when I start the PC the diagnostics show 74..75 MHz. Then I set to 45 MHz restart Mach it shows: 44...45 MHz. After setting to 75 MHz and restarting MAch it shows 74..75 MHz again.
The noise of the servos sounds strange, wrong frequenzy?? On the 45 Mhz settings the servos do move but to slow and after the final restart everthing is fine.

Dirk

Offline fdos

*
  •  326 326
    • View Profile
Re: Problems with 75 MHz settings
« Reply #3 on: September 16, 2007, 09:10:27 AM »
You need to retune your settings for the new pulse rate.   Maybe your acceleration and or speed is now too high for your motors/drives.

Wayne....
Re: Problems with 75 MHz settings
« Reply #4 on: September 16, 2007, 09:20:15 AM »

>> Maybe your acceleration and or speed is now too high for your motors/drives.

I don´t think so, it is working after the procedure I described earlier. I´m using the same speed and acceleration as before, now I just doubled the resolution.

Dirk

Offline fdos

*
  •  326 326
    • View Profile
Re: Problems with 75 MHz settings
« Reply #5 on: September 16, 2007, 09:57:25 AM »
doubled resolution?    Increasing pulse rate will just increase speed not resolution.  Unless you had a pulse multiplier turned on before and not now.

What drives/motors/encoders  are you using?

Wayne....
Re: Problems with 75 MHz settings
« Reply #6 on: September 16, 2007, 10:17:19 AM »
I´m using UHU-Servo controllers. With the 45 MHz setting I had the multipier on "2" and now with 75 MHz it is "4". The speed of 5500 mm/min and acceleration of 300 mm/sec² is the same! Actually the resolution is doubled!!

So believe me it is not the hardware, the system is working fine after reseting the sofware (not rebooting the pc) twice as decribed before , I just want to awoid this procedure.

Dirk