Hello Guest it is May 06, 2021, 08:25:08 PM

Author Topic: Help on new Build, Y not homing no matter what I try  (Read 301 times)

0 Members and 1 Guest are viewing this topic.

Help on new Build, Y not homing no matter what I try
« on: November 28, 2019, 08:57:11 AM »
I have a new CNC (Mach3) build I just completed and itching to try it out. Everything works EXCEPT Y homing. I currently have it setup based on some references here with the A axis slaved to the Y, that works I can job back and forth fine. I have 2 end stops on the right Y side, one for Y HOME and one for Y++. I have one endstop on the left Y set to A HOME. I can see the switches change states if I manually trigger them and Idle is grey on the screen so they are not inverted. In Homing I have X Neg, Y Neg and A Neg all setup. I changed the script for the Ref All Home to what was found here for homing dual end stops.

Now, here is where I don't know what is failing or not happening. If I press the button X homes just fine, then nothing. I get the script done message (it just sends a few DoButton()) and that is it. The odd thing is if I try and jog at this point, it says you cannot jog during homing so Mach thinks it is still homing but the Y axes Never moves. I do have A set as the Slave axis to Y and have Unchecked the Home Slave with Y as noted here somewhere. I even edited the script to just send the Ref Y and also tried just pressing the Ref Y button and it does nothing but make Mach thing it is homing and I have to reset after each attempt to get where I can jog.

I have tried looking everywhere for anything useful as far as debug goes but mach doesn't really output much to give me any hints. I am using the DDUM4 board but do not know if mach sends a special homing command to the board or if it just moves the motors and waits for a switch hit, either way the Y axis Never moves while trying to home. I figured if the inputs were wonky it would at least think it was homed and do the backoff but that never happens either. Any thoughts?