Hello Guest it is May 17, 2021, 06:13:27 PM

Author Topic: smooth braking not working.  (Read 346 times)

0 Members and 1 Guest are viewing this topic.

smooth braking not working.
« on: October 31, 2019, 06:52:08 PM »
I'm upgrading from Mach3 to Mach4 and it's gone mostly well.   but when I do a manual move, there are not movement limits.  I hits the end of travel bumpers with no deceleration. 

I try and change things in the Machine Setup/Home Settings and Soft Limits button show in the setup documents ISN'T THERE?

How do I get that button enabled, and how do I setup the soft limits and enable what I think is called smooth braking.

Offline mark4

*
  •  167 167
    • View Profile
Re: smooth braking not working.
« Reply #1 on: November 05, 2019, 12:02:27 AM »
Hi What screen are you using?
There is a pushbutton on the tab screen for enabling soft limits. this needs to be on or the soft limits or the soft limits are on. Also have you homed the machine as homing sets your soft limits also
Re: smooth braking not working.
« Reply #2 on: November 05, 2019, 01:25:00 AM »
Hi,
Mach3 had a setting called a 'Slow Zone' which reduced axis velocity within a given distance of a soft limit. Mach4 does not
have that feature programmed into it but you could easily program it into either the PLC script or the PMC script. The
PMC script is the equivalent of Mach3 Brains.

The question I ask is 'do you need it?'. If Mach determines that your code or jogging will take you out of bounds ie exceed
your soft limits it will 'limit' out and stop. If it approaches a soft limit at full speed provided it has time to decelerate an reverse away
it can carry on at full speed as far as I'm concerned, Mach will determine if that is the case, and if not, Estop 'Soft Limit
Exceeded'. So who cares about a slow zone?

I've been using Mach4 for four years and have not missed 'Slow Zone'.

Craig
My wife left with my best friend...
     and I miss him!