Hello Guest it is March 07, 2021, 04:40:15 PM

Author Topic: Cutting wrong dimensions in only one spot  (Read 2879 times)

0 Members and 1 Guest are viewing this topic.

Cutting wrong dimensions in only one spot
« on: October 25, 2019, 01:14:56 PM »
Mach3, ESS Smoothstepper, Rhino5, Madcam.

I've tried backlash compensation on and off. Have my CV settings at .1, no other CV boxes checked. Tried IJ mode absolute and incremental. Talked with CAM developer about all settings.  Post is cutting with G2/G3. 

I've played with motor settings. Tried cutting at 1IPM.... I'm stumped.

Pic shows what's going on. Black shape is what I'm trying to cut. Red shape is cut part measured on CMM. I'm always getting this deviation at around the 10 o'clock position no matter what I try. The toolpath is correct, I really believe it's something in mach3
Re: Cutting wrong dimensions in only one spot
« Reply #1 on: October 25, 2019, 02:21:04 PM »
Pic didn't load first time
Re: Cutting wrong dimensions in only one spot
« Reply #2 on: October 25, 2019, 02:44:27 PM »
And pic rotated, so cut issue is at 8 o clock.  Not 10 o clock as mentioned in first post

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cutting wrong dimensions in only one spot
« Reply #3 on: October 26, 2019, 01:39:25 AM »
Can you please attach your Gcode that is causing the problem ?
KEEP SAFE !

Offline Graham Waterworth

*
  • *
  •  2,275 2,275
  • Yorkshire Dales, England
    • View Profile
Re: Cutting wrong dimensions in only one spot
« Reply #4 on: October 26, 2019, 08:16:46 AM »
How is it being measured, 3 or more points on an arc or a digitised path?
« Last Edit: October 26, 2019, 08:11:42 PM by Graham Waterworth »
Without engineers the world stops
Re: Cutting wrong dimensions in only one spot
« Reply #5 on: October 26, 2019, 12:09:23 PM »
I'll have to post the gcode on Monday.
It's measured with 3600 points, .0001" resolution. Very accurate.  The cut part discrepancy is .023", so pretty obvious.

Offline Graham Waterworth

*
  • *
  •  2,275 2,275
  • Yorkshire Dales, England
    • View Profile
Re: Cutting wrong dimensions in only one spot
« Reply #6 on: October 26, 2019, 12:49:06 PM »
Are you cutting this on a mill or router type machine?
Without engineers the world stops
Re: Cutting wrong dimensions in only one spot
« Reply #7 on: October 26, 2019, 03:37:25 PM »
Mill. Cutting mild steel. I can do skim cuts of .001" and it will cut exact wrong shape

Offline BR549

*
  •  6,944 6,944
    • View Profile
Re: Cutting wrong dimensions in only one spot
« Reply #8 on: October 26, 2019, 07:52:45 PM »
If you are cutting cam lobes then teh Black line is bad code. Teh acel / Deacel ramps should be symetrical on each side of teh lobe. The red line appears to be more symetrical than teh black line. The black line has an inverted ramp which is Bad lobe design in most cases.

From what data did you plot the black line. I would like to see teh Gcode that cut it.

Just a thought, (;-) TP

Offline Graham Waterworth

*
  • *
  •  2,275 2,275
  • Yorkshire Dales, England
    • View Profile
Re: Cutting wrong dimensions in only one spot
« Reply #9 on: October 26, 2019, 08:10:09 PM »
Are you using tool comp?
Without engineers the world stops