Hello Guest it is May 14, 2021, 10:28:49 AM

Author Topic: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!  (Read 537 times)

0 Members and 1 Guest are viewing this topic.

Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« on: October 16, 2019, 09:40:52 PM »
Looked through this forum today and can't find an answer to my problem.

I have my Z Home +/Touch Probe wire to pin #13/input #4 on the G540
I have my ESS pins for this as Port 1/Pin 13 for Z Home and Limit+ & Port 3/Pin 4 for the Touch Probe.
Homing my machine works fine. When I start the touch probe cycle on my router the routine error's out saying Motor 2++ has been triggered. This is making Mach4 believe the Z Home position has been reached which his not correct.

I previously used this same hardware with Mach3 and only installed Mach4 changing nothing with my wiring. Didn't write down the old pin assignments from Mach3 or I might not have a problem.

Does anyone know the correct pins and inputs assignments for the Z-Axis and Probe when setup like this?

Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #1 on: October 17, 2019, 03:50:28 AM »
Hi,
the question I ask is why when you have an ESS with 51 inputs/outputs you are restricting yourself to
one pin fulfilling multiple roles?. If you bought a second breakout board like a bi-directional C10 ($23) then
you would have enough inputs to have one pin per switch/touch plate or what have you.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #2 on: October 17, 2019, 08:32:32 AM »
Trust me! That is forefront in my mind right now!
It has been a frustration in he past. My only delay is in the fact that it work previously with Mach3.
For my CNC Router if it were to work as it previously did I don't need any other I/O ports.
Now for other CNC equipment I have it has always been what I've done.
Don't have a problem spending the small amount of money to make the upgrade so probably will do it!

Offline dws

*
  •  24 24
    • View Profile
Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #3 on: October 17, 2019, 09:01:45 AM »
It should work regardless of whether the axis home and limit are the same switch / pins.

I am not sure what is causing your error; however, Mach 4 is not the problem with using home and limits on the same pin. There must be something else wrong with your settings.

I have an AVID CNC that came with Mach3 and its home and limit switches are the same switch for each axis. I upgraded it to Mach4; and, I never had a problem like this.
David
Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #4 on: October 17, 2019, 03:28:08 PM »
Hi,

Quote
It has been a frustration in he past. My only delay is in the fact that it work previously with Mach3.

Yes it will work, almost exactly as it did in Mach3, just as dws has confirmed but.......you used the word 'frustration'......
so do you want to relieve that frustration or not?

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #5 on: October 17, 2019, 04:40:02 PM »
It should work regardless of whether the axis home and limit are the same switch / pins.

I am not sure what is causing your error; however, Mach 4 is not the problem with using home and limits on the same pin. There must be something else wrong with your settings.

I have an AVID CNC that came with Mach3 and its home and limit switches are the same switch for each axis. I upgraded it to Mach4; and, I never had a problem like this.

Mach4 Software is not the problem I'm aware of that. It's my initial setup of the software. I somehow can't remember how I had the pins and also input settings assigned for Z- and the probe. Not even sure if Z- is necessary since technically there is no Z- Limit. Z- in my head should be the touch pad instead.

Offline dws

*
  •  24 24
    • View Profile
Re: Mach4 G540 ESS Smoothstepper Touch Plate Error!!!
« Reply #6 on: October 17, 2019, 05:39:20 PM »
You can set Soft Limits for the Z- Limit and all other limits. With Soft Limits, the machine will stop movement at the limits; instead of erroring when the limit switches are tripped.

But, I think that you still have something wrong with your settings. Probing should not cause the limit to trip.
« Last Edit: October 17, 2019, 05:42:11 PM by dws »
David