Hello Guest it is July 05, 2020, 05:15:59 PM

Author Topic: MACH III "Run from Here" not working correctly  (Read 347 times)

0 Members and 1 Guest are viewing this topic.

MACH III "Run from Here" not working correctly
« on: September 20, 2019, 12:29:14 PM »
Hello Forum,
I am running MACH III v.R3.043.066.  The software version works fine except when I have to interrupt the program.  When I select "start from here", the program resets itself and starts the spindle but then just sits there.  No X-Y movement.
Can anyone help me with finding a fix?
Thanks all!

Offline olf20

*
  •  317 317
    • View Profile
Re: MACH III "Run from Here" not working correctly
« Reply #1 on: September 20, 2019, 06:59:46 PM »
I use Mach3, ESS, and 062 version. It works for me.
olf20 / Bob
Mach3, Atlas Knee Mill, 4th Axis, VcarvePro, ESS, Super PID.
Been Heating with corn since 1998

Offline Graham Waterworth

*
  • *
  •  2,102 2,102
  • Yorkshire Dales, England
    • View Profile
Re: MACH III "Run from Here" not working correctly
« Reply #2 on: September 20, 2019, 08:30:50 PM »
If there is not enough info for mach to start then it will just sit there, E.G. it is in G01 mode with no feed rate
Without engineers the world stops
Re: MACH III "Run from Here" not working correctly
« Reply #3 on: September 20, 2019, 10:09:45 PM »
Thanks, I see.  What can I do to correct the problem?  Is there a bug in the program?  Seems to me that it should find all the info it needs "running" through the program to the restart point which is what I think it should be doing.....
Re: MACH III "Run from Here" not working correctly
« Reply #4 on: September 21, 2019, 12:13:47 AM »
Hi,
Run-From-Here (RFH) has always been a little problematic.

You are correct the ghost run through the code to the start point should initialise all the mode registers, but as Graham
points out any shortfall will result in a stalled program.

May I suggest keep experimenting until you find the correct procedure with your installation. RFH gave me grief until I worked
out how to do it properly and even then.....deviate from that procedure results in a crash.

Its been four years since I switched the Mach4 so I'm now vague on the details but I certainly did get Mach3 RFH to work.

Craig
My wife left with my best friend...
     and I miss him!
Re: MACH III "Run from Here" not working correctly
« Reply #5 on: September 22, 2019, 08:03:56 PM »
Thanks everyone for responding.  Looks like I will have to fool around with it to see if I can find a solution.  BTW,
how can I acquire the latest version of Mach III? This may have been a bug with the current licensed version I am now using.
Re: MACH III "Run from Here" not working correctly
« Reply #6 on: September 22, 2019, 10:59:46 PM »
Hi,
RFH has ALLWAYS been problematic no matter what version of Mach3.

All development on Mach3 ceased six years ago in favor of Mach4. If you wish to persue a Mach software solution where
you can expect bugs to be fixed then Mach4 is it.

Craig
My wife left with my best friend...
     and I miss him!
Re: MACH III "Run from Here" not working correctly
« Reply #7 on: September 23, 2019, 03:20:35 PM »
Thanks Craig and thanks everyone.  I will upgrade to Mach IV.  That should do it for this thread.