Hello Guest it is November 27, 2021, 07:17:39 AM

Author Topic: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?  (Read 674 times)

0 Members and 1 Guest are viewing this topic.

Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« on: August 12, 2019, 06:35:16 AM »
Mach4 (4.2.0.4284) Status Bar (wxLathe.set)

Any reason why G99 shows up twice on the current active status Bar??

When I change to G98, one of the G99's changes to G98, but the other remains at G99?
« Last Edit: August 12, 2019, 06:44:11 AM by robertspark »
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« Reply #1 on: August 12, 2019, 02:41:00 PM »
Hi,
that initialization string is part of the profile and is not easily overwritten or changed. This thread is broadly similar:

https://www.machsupport.com/forum/index.php?topic=41351.msg271124#msg271124

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« Reply #2 on: August 12, 2019, 03:48:50 PM »
You can use the ModalWizard to see which modal groups those are coming from.
Re: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« Reply #3 on: August 13, 2019, 05:16:57 AM »
Craig, no its not the same thing

jbuehn, thanks that gave me the clue I was looking for.

It is definitely a bug, and it affects all releases from 4.2.0.4284 back to 4.2.0.4162

Attached is the screenshots from the Modal Wizard and the status line/ bar from 4.2.0.4162.

The wizard also appears to have a bug too....

As you can see modal group 05 says feedrate mode G99 (which is correct), which the wizard says is "R return point", which is a wizard bug...... it should read "Feed Per Revolution"

And then when you look at modal group 10 it says Active GCode "G99.0", this is a Mach4 bug as it should say G99.1 , which is "R Point Return"

These are covered in the Lathe GCode Programming Manual, Chapter 2: GCodes (PDF page 7, 8 & 9)

The problem is its lathe and turning and not many people are probably interested..... hence why it gets missed / not put right.
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« Reply #4 on: August 14, 2019, 09:53:11 AM »
This was showing Mill modal's, I have added some code to swap to show lathe modals. I also kill groups that are not in Lathe mode so you will not see an extra data.
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Mach4 (4.2.0.4284) Status Bar .... confused (wxLathe.set) ?
« Reply #5 on: August 14, 2019, 10:12:37 AM »
thanks Brian, much appreciated, us lathe users tent be be a forgotten minority in the CNC world
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”