Hello Guest it is August 12, 2020, 07:08:48 PM

Author Topic: THC issues. Torch dives in holes  (Read 561 times)

0 Members and 1 Guest are viewing this topic.

THC issues. Torch dives in holes
« on: August 10, 2019, 09:22:15 AM »
Hello together,

Please help, as you are my last hope.

We installed a THC module from a small local manufacturer. It works pretty well, and keeps the torch at the constant height over the plate, but it keeps diving in the holes.

We set the THC min speed (anti dive) to 90%, and it keeps diving.
Lets say the code writes a feedrate of 1000mm/min. The FRO is set to 100% and the torch dives. By manually dragging the FRO down so that it is 10% smaller that actual feedrate, MACH3 checks the difference and disables the THC.

Is there any possibility to drag the FRO down automatically, so that MACH sees the difference to the actual feedrate and disables THC? By integrating some macros of brains?

We prepare the code in Pronest. The manufacturer of the THC gave us a post processor that should work with his module. But we still have the diving torch.

I attach the plasma profile, the code and the pronest postprocessor.

Please take a look and help with a piece of advice.

P.S. in the postprocessor file, just change the file extantion to cff

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: THC issues. Torch dives in holes
« Reply #1 on: August 10, 2019, 10:13:00 PM »
There are 2 anti dives. Anti corner dive and anti dive.  Anti corner dive is controlled from teh Mach side and teh Anti Dive(hole) is controlled from teh THC side. It appears you are only addressing teh Anti Corner dive and NOT teh anti Dive(hole).

Are you SURE you are setting teh AntiCorner Dive correctly ? IF I remember correctly teh setting is a percent of slowdown from programmed feedrate. So it would need to be 10% ????

Just a thought, (;-) TP
« Last Edit: August 10, 2019, 10:17:25 PM by BR549 »
Re: THC issues. Torch dives in holes
« Reply #2 on: August 11, 2019, 03:13:05 AM »
Hello,

I am new to mach3, and i didn't know there are 2 "antidives". I set the value of 90 in the right bottom corner on the main screen. It is the same value as in the Settings Tab in the right top corner.

The thing is that as the FRO drops lower than these 90 percent, mach3 disables the THC. But I have to do this manually.

In Pronest, there are cutting tables integrated, where the soft calculates an individual feedrate if the holes are bigger or smaller than a specified diameter. But somehow it is not translated to MACH3.

For example if the basic feedrate is 1000mm/min, and the hole is smaller than 20 it will have a 50%feedrate. This is translated in the G-code. And if in mach3 i manually change the FRO it cuts more slowly.

What are the commands in g-code for mach3 that enables and disables THC.

Thank you and best regards

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: THC issues. Torch dives in holes
« Reply #3 on: August 11, 2019, 06:48:22 AM »
Adjusting teh feedrate in Gcode does nothing for antiDive. The antidive is based on teh programmed feedrate and teh drop from there. Adjust your antidive feedrate to 10% or less (;-) and try it again. It works fine IF you use teh correct values.

Remember put teh value of 10 or less in teh setup field. NOT 90

(;-) TP
Re: THC issues. Torch dives in holes
« Reply #4 on: August 12, 2019, 12:24:30 PM »
Hello,

I made the change, seems to be the same result...

Is there maybe a macros or a "brain"to fix this problem....?

Or maybe the postprocessor doesn't have any important features?

Thank you

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: THC issues. Torch dives in holes
« Reply #5 on: August 12, 2019, 02:40:47 PM »
Teh anti corner dive is an internal process. IF teh actual feedrate drops below teh threshold you set then it blocks teh THC down function and teh torch cannot dive until teh actual feedrate goes back above teh threshold value.

Do you have it turned ON ??

(;-) TP
Re: THC issues. Torch dives in holes
« Reply #6 on: August 13, 2019, 09:38:37 AM »
Hello,

I set it on, changed the value to 10% and i get the same effect of diving. The THC doesn't have an integrated "anti dive" function.

By making the code in Pronest, and exploring the postprocessor, I saw that I have two M codes that have to switch the THC on and off.

It is M50 (off) and M51 (on) that are integrated in the code. During the cutting process plasma freezes for a fraction of second by reading this code, but the THC remains in the ON position, even if the M50 code says to turn it off.

I suppose I need some Macros that can interpret this M codes in enabling and disabling the THC command.

Can somebody help me out here, cause I have no clue in this stuff.

Best regards

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: THC issues. Torch dives in holes
« Reply #7 on: August 13, 2019, 02:11:02 PM »
OK back to teh beginning. Are you using a Mach3 plasma profile ?? When you say it dives in a hole what exactly do you mean. It dives when cutting a circle or it dives when crossing a void (hole).

I have used Mach3 for
plasma for MANY years and never have I see anti corner dive not work if setup correctly.

(;-) TP