Hello Guest it is April 08, 2020, 04:22:33 PM

Author Topic: Continuous jogging won't stop  (Read 325 times)

0 Members and 1 Guest are viewing this topic.

Continuous jogging won't stop
« on: July 18, 2019, 09:36:32 AM »
Using Mach 4 and I am having an issue while jogging. Sometimes it works as expected and other times the jog just continues on its own. Has anyone found a solution to this?
Using the HiCON Integra with the 7737 board.

Offline fast89

*
  •  142 142
    • View Profile
Re: Continuous jogging won't stop
« Reply #1 on: August 25, 2019, 03:02:51 PM »
On mach3, you could see this if your are running a parallel port and the motors are tuned too fast. Reducing the kernal speed and motor velocity would always fix it.
Re: Continuous jogging won't stop
« Reply #2 on: August 25, 2019, 04:44:30 PM »
Hi,
whats happening is that jog moves are being stacked up in the buffer before execution. In essence you are providing
more moves than the machine can keep up with. It is not a fault.

A couple of things you can do are:
1) increase the jog speed by tuning your motors with as high acceleration and velocity as possible.
2) reduce the step size.

I have this problem also if I use a jog increment of 1mm per mpg step. I can spin the MPG fast enough that the machine
lags behind and even when I stop spinning the MPG it will carry on moving until all those moves have been executed,
very un-nerving. I find however if I reduce the maximum step size to 0.5mm per MPG click the problem is vastly reduced.

When jogging in this fashion I'm often trying to find an edge or similar so I want the jog velocity to be low. When jogging at
maximum step size you often want to traverse at speed. It is possible to write some Lua code that will jog fast at max step
size, thereby reducing the over-run, and slow when at less than maximum step size for edge finding etc.

Craig

My wife left with my best friend...
     and I miss him!
Re: Continuous jogging won't stop
« Reply #3 on: August 27, 2019, 12:19:02 AM »
I've just tested what you wrote in point 1. and I can't reproduce the issue.
I pressed different jog keys kept the keys down, pressed the Reset button and the jogging always stopped.
I have tested version 1.2102 and I've tested with UC100 and with UC300ETH-5LPT, I had these at hands now.
I could not reproduce the issue with any of the mentioned controllers.