Hello Guest it is May 06, 2021, 08:34:17 PM

Author Topic: NOOB Alert (MACH4 & 57CNC Issues)  (Read 441 times)

0 Members and 1 Guest are viewing this topic.

NOOB Alert (MACH4 & 57CNC Issues)
« on: June 09, 2019, 12:39:56 PM »
OK, Mach4 is up and running and I got some motion.  STILL issues with Z doing its own thing in regards to direction, guessing this might be a setting in Mach?

Video: https://youtu.be/rvbayc26z-c

Re: NOOB Alert (MACH4 & 57CNC Issues)
« Reply #1 on: June 09, 2019, 12:40:50 PM »
This machine has no limit switches or homing, so it is weird that it changes direction all on its own, sometimes at the extents of motion, sometimes in the middle of travel when clicking "Z+" multiple times in succession...
Re: NOOB Alert (MACH4 & 57CNC Issues)
« Reply #2 on: June 09, 2019, 02:35:30 PM »
Hi,
that sounds like noise on the Dir pin of your Z axis driver.

Are all your steppers driven off that one board as pictured in the video?
Can you tell me the model number of the drive ICs on that board?

Craig
My wife left with my best friend...
     and I miss him!
Re: NOOB Alert (MACH4 & 57CNC Issues)
« Reply #3 on: June 09, 2019, 03:21:43 PM »
The Pokeys 57CNC is the motion controller, then I have the 3 steppers driven by these stepper motor drivers:

https://www.amazon.com/gp/product/B06Y5VPSFN/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1

The drivers work well, I am just confused on why DIR switches on its own.  If you look at the video, when the Z carriage hits the vertical max instead of crashing, it just changes direction on its own.
Re: NOOB Alert (MACH4 & 57CNC Issues)
« Reply #4 on: June 09, 2019, 07:00:09 PM »
Update: Replaced Z stepper and seems to have helped the issue.  Connections are all soldered, however I am still apprehensive over how robust this is going to be.

Now we are having issues with losing connection to the Pokeys.  Tried dry-running some Gcode and in both Mach4 and Mach3 the program stalls out because of a lost connection.  Has anyone else experienced this?  We REALLY need to get this fixed tonight.  Creeping towards desperation mode...

Wondering why all this seems so fragile.  Mach4 will literally hang up on Gcode, tries re-establishing a connection (which sometimes happens) and then the Mach4 software will randomly just crash.  The software is licensed, etc.  And, still trying to get Go To Zero to work (that's a different issue entirely, which I believe has been covered here)

Are my expectations too high to get this working?  Is this setup robust and we are just doing something wrong?

Offline Tweakie.CNC

*
  • *
  •  8,704 8,704
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: NOOB Alert (MACH4 & 57CNC Issues)
« Reply #5 on: June 10, 2019, 02:37:42 AM »
Just an observation from your video...

You are using USB connection between your PC and the 57CNC and you also appear to have a couple of USB memory sticks connected to the PC.
It depends on exactly how the PC polls it's USB hub or hubs but leaving memory sticks in the PC when running Mach3 and using a USB connection to the motion controller can be very bad news indeed - I have not tried it but maybe Mach4 is similar ?

I think you should remove the memory sticks and change your PC to 57CNC connection to Ethernet (which is far superior to rejection of electrical noise issues etc.) and see if this resolves the problems.

Tweakie.
KEEP SAFE !