Hello Guest it is January 15, 2021, 09:33:37 AM

Author Topic: Fusion 360 / Autodesk Post Processors.  (Read 3163 times)

0 Members and 1 Guest are viewing this topic.

Re: Fusion 360 / Autodesk Post Processors.
« Reply #10 on: January 09, 2021, 11:42:11 PM »
As a temporary ‘workaround’ until you get a post processor sorted, it is no real problem to use Notepad ‘Find and Replace’ function to automatically change every M11P1 to M62P1 and then every M10P1 to M63P1 (or whatever P#) to convert a Mach3 laser Gcode to a Mach4 laser Gcode.

Tweakie.

I've changed my fusion post processor to the "mach 3 laser" one that was posted here, and managed to get fusion to spit out G code. first issue was it kicking me an error saying that UCCNC needs me to put "compensation in computer not in controller..." for something. I'm using an ethernet smooth stepper so... eh? the post was clearly made for UCCNC.

I got it to spit out a simple circle and square g code, and did like you said, find / replace the m11 to m62 commands and m10 to m63. that at least made it able to move and perform the toolpath, but the laser will not fire. I have a manual 5v button I have wired and confirmed that I can force the laser to fire, and I also have it set up in mach 4 with the laser screen- if I hit the TEST LASER button, I can make Mach fire it from that screen. I can also fire the laser in mach if I reassign it to something like a coolant pin output or something... anyways, mach can fire it, and I'm SO CLOSE. but I can't seem to get the g code to fire it. any ideas? M62 and m63 isnt doing anything when I run it.

thank you

Offline Tweakie.CNC

*
  • *
  •  8,611 8,611
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Fusion 360 / Autodesk Post Processors.
« Reply #11 on: January 10, 2021, 12:56:21 AM »
Perhaps re-trace your steps…

Go through the ESS laser set-up details here;   https://www.warp9td.com/index.php/faq/faq-mach4#LaserSetup
And carefully check that you have completed each step correctly.

My original ESS / Mach4 laser test file is  ‘Star Trek.tap’ located in the .zip file here; https://www.machsupport.com/forum/index.php?topic=18345.0
Run this Gcode and if you have set everything up according to the ESS set-up details then your laser will fire correctly.

Hope this helps.

Tweakie.
KEEP SAFE !