Hello Guest it is October 24, 2021, 09:28:16 PM

Author Topic: Mach 3 won't jog with keyboard  (Read 29075 times)

0 Members and 1 Guest are viewing this topic.

Offline RMT

  •  13 13
    • View Profile
Re: Mach 3 won't jog with keyboard
« Reply #10 on: September 01, 2007, 09:20:12 AM »
I deleted the jog button right of the bat, except on the diagnostics page , and it was jogging fine, I will try that , but what started it that I wanted a toggle for fast and slow jog like the shift key but on the screen, than I found the slowjog increase and decrease buttons and added them to the set up screen, thats when it stopped jogging with the keyboard, so I think its something else, especially since the jog on button never worked on the screen anyways

Turns out You right You have to have a jog button on the page for the keyboard to work.

That;s it .... got everything but the oem code for the shift key....anybody know?

Re: Mach 3 won't jog with keyboard
« Reply #11 on: September 04, 2007, 06:58:56 PM »
Yes I too have lost my ability to use my keyboard for jogging, in fact I can’t switch between step and continues.  I can set the number for the incremental moves, but when I try to select it the light does not light up.  It worked fine when I calibrated the machine, but since then it stopped working. The only thing I can think that I changed since then was I added the pins for spindle and coolant start and stop. I went into the configure screen and turned them off but it didn’t change anything. Any ideas, I have been watching this post to help find the answer to my problem as well.


Offline jimpinder

  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: Mach 3 won't jog with keyboard
« Reply #12 on: September 05, 2007, 07:44:15 AM »
In one of the tutorials Art mentions that jogging is switched off on some of the screens so that  you do not accidently jog the machine out of position once it is set up. This is because ( I think) jogging only affects one set of co-ordinates, and if you have set other co-ords, or are not running in machine co-ords, the two sets will get out of reference with each other.

On my Turn program, jogging works only on the "Manual" page as you are setting your work up. Once you move page, say to input code directly to the machine via the key board, or to enter and run a program, jog will not work.

On my Mill program, as far as I can remember, jogging only works on screen 1
Not me driving the engine - I'm better looking.