Hello Guest it is August 07, 2020, 12:08:33 AM

Author Topic: New guy frustration LOL  (Read 2462 times)

0 Members and 1 Guest are viewing this topic.

New guy frustration LOL
« on: April 02, 2019, 09:13:41 AM »
I am new to the forum new to CNC and new to mach3 so here I am.
I bought a machine and I am now trying to configure mach3 and I am moving along slowly and having troubles with my probe/ touch plate.
Right now I am looking for a new script that will enable me to use the touch plate. The one that I got from YouTube seemed to work but it would send my spindle 6in off the material surface and when I tried to run code it ran the code 6 in off the work surface. So I want to find a new script and see if that was the issue.
any and all help is appreciated and I will do my best to learn to navigate the forums as soon as possible thanks for your patience and help.
I am in the United States. Mid Michigan to be exact

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: New guy frustration LOL
« Reply #1 on: April 02, 2019, 09:36:04 AM »
Are you using the parallel port, or a motion controller?
If a motion controller, which one.

Most chinese motion controllers do not support the GetVar command properly, which most autozero macros use.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: New guy frustration LOL
« Reply #2 on: April 02, 2019, 09:45:53 AM »
I have a Mach 3 motion controller called WHHC MKX-IV. Runs thru the USB

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: New guy frustration LOL
« Reply #3 on: April 02, 2019, 10:46:57 AM »
Then make sure you do NOT use a macro that has GetVAR() in it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline reuelt

*
  •  440 440
    • View Profile
Re: New guy frustration LOL
« Reply #4 on: April 02, 2019, 02:19:03 PM »
I am new to the forum new to CNC and new to mach3 so here I am.
I bought a machine and I am now trying to configure mach3 and I am moving along slowly and having troubles with my probe/ touch plate.
Right now I am looking for a new script that will enable me to use the touch plate. The one that I got from YouTube seemed to work but it would send my spindle 6in off the material surface and when I tried to run code it ran the code 6 in off the work surface. So I want to find a new script and see if that was the issue.
any and all help is appreciated and I will do my best to learn to navigate the forums as soon as possible thanks for your patience and help.
I am in the United States. Mid Michigan to be exact
Attached is Tool Probe VB code I use (but I use with Parallel Port).
You need to change 2 Z values to suit your plate thickness and retracting height (commented in RED)
Or get the idea and edit the code you already have.

Reuel
« Last Edit: April 02, 2019, 02:23:13 PM by reuelt »
"the gift of God is eternal life through Jesus Christ our Lord"
Re: New guy frustration LOL
« Reply #5 on: April 02, 2019, 02:27:02 PM »
[quote
Attached is Tool Probe VB code I use (but I use with Parallel Port).
You need to change 2 Z values to suit your plate thickness and retracting height (commented in RED)
Or get the idea and edit the code you already have.

Reuel
[/quote]

Thank you... I think thats the one I have now, But I will try and compare it.

Offline reuelt

*
  •  440 440
    • View Profile
Re: New guy frustration LOL
« Reply #6 on: April 02, 2019, 03:57:06 PM »
'Alternative Probe z surface macro 
‘Test probe is working first before using this macro

FeedCurrent = GetOemDRO(818) 'Get the current settings, OEM DROs (818)=Feedrate DRO
ZCurrent = GetOemDro(802) 'OEM DROs (802)=Z DRO
GageH = GetOEMDRO(1001) 'OEMDRO(1001)=Gage Block Height
ZNew = ZCurrent - 6 'probe down max. 6 inches
Code "G90F5" 'slow feed rate to 5inches/MIN
SetOemDRO(818,5)
Code "G4 P1" 'Pause 1 second to give time to position probe plate
Code "G31 Z" &ZNew
While IsMoving()
Sleep(10)
Wend
Call SetDro (2,GageH) 'DRO(2)=Z DRO
FinalMove = GageH + 1 ‘move 1 inch above gage height
Code "G0 Z" &FinalMove
Code "F" &FeedCurrent 'restore starting feed rate
SetOemDRO(818,FeedCurrent)
« Last Edit: April 02, 2019, 04:05:09 PM by reuelt »
"the gift of God is eternal life through Jesus Christ our Lord"
Re: New guy frustration LOL
« Reply #7 on: April 02, 2019, 07:07:10 PM »
I'll give you my run down....
After turning on machine
I hit Mach  cords and zero all home.
After it finishes moving, I click the xyz zero buttons.
Then I move spindle over material datum and line it up. And zero my x&y buttons
I get touch plate and hit Auto Tool Zero.
It touches, zips up 5" stops and creeps up one more. The Z drop says....1".
I load Gcode and press go.....
Spindle turns on, drops...1" and start running code....5" off material
Re: New guy frustration LOL
« Reply #8 on: April 02, 2019, 07:14:29 PM »
Hi,
I rather think that Gerry has already alluded to the problem, your controller does not conform to Machs
expectation with regards the implementation of G31 probing. You may be required to touch off in Z manually
or buy a controller that does conform.

Craig
My wife left with my best friend...
     and I miss him!
Re: New guy frustration LOL
« Reply #9 on: April 02, 2019, 07:19:20 PM »
My machine came with a touch plate, and the vendor told me it works(but it's up to me to figure out the set up)