Hello Guest it is May 23, 2019, 01:32:36 PM

Author Topic: All home, precise backward .mm - problem  (Read 71 times)

0 Members and 1 Guest are viewing this topic.

All home, precise backward .mm - problem
« on: March 12, 2019, 05:24:52 AM »
Hi, friends
I have a problem with homing.
Usually when I press "ALL HOME", it first go home z axis then X and Y.
When the x axis hits the switch at end of movement, then the ax gets backwards few .mm, and then slowly to hit the switch again (for better precision, I suppose).
My problem is ...sometimes when the axe going back - not going far enough and do not release activated homing switch, and machine stop with message (emergency stop active-endstop)!

- I use the same switch for homing and endstops
So where to control how many steps or .mm axe going back before going to precise hiting the switch?

lp, chris
Re: All home, precise backward .mm - problem
« Reply #1 on: March 12, 2019, 06:24:52 AM »
Hi,

Quote
So where to control how many steps or .mm axe going back before going to precise hiting the switch?

That is not how Mach operates. When homing it will drive until the switch activates and then backup until it
deactivates. Then it resets the machine coordinate for that axis. Mach does not move a certain distance.

There are some external motion controllers that DO have that capacity, the 57CNC by PoKeys for instance,
but it is not a supported feature of Mach's parallel port driver.

The real problem is that you have a switch with too little hysteresis. Snap action microswitches are good for home switches
whereas inductive proximity switches often have problems like you have described.

Ideally you would have three separate home switches, each with its own input pin AND six limit switches, there again ideally
all on their own inputs but commonly wired all together in series. The important idea is that limit switches should NOT
do double duty. This is easily possible if you have two parallel ports or an external controller with two or more ports
as you have plenty of inputs spare.

Craig
My wife left with my best friend...
     and I miss him!

Offline reuelt

*
  •  444 444
    • View Profile
Re: All home, precise backward .mm - problem
« Reply #2 on: March 12, 2019, 07:04:24 AM »
Hi, friends
I have a problem with homing.
Usually when I press "ALL HOME", it first go home z axis then X and Y.
When the x axis hits the switch at end of movement, then the ax gets backwards few .mm, and then slowly to hit the switch again (for better precision, I suppose).
My problem is ...sometimes when the axe going back - not going far enough and do not release activated homing switch, and machine stop with message (emergency stop active-endstop)!

- I use the same switch for homing and endstops
So where to control how many steps or .mm axe going back before going to precise hiting the switch?

lp, chris

First try to increase the debounce on top right corner of config | General Config page.
(see attached)
I solved my problem by just increasing denounce settings to 50. Try 50 or even more until your machine is stable.
"the gift of God is eternal life through Jesus Christ our Lord"
Re: All home, precise backward .mm - problem
« Reply #3 on: March 12, 2019, 07:18:02 AM »
Thanx for hint...I'll try