Hello Guest it is December 11, 2019, 01:07:54 PM

Author Topic: Auto tool zero...Z-probing  (Read 486 times)

0 Members and 1 Guest are viewing this topic.

Auto tool zero...Z-probing
« on: March 03, 2019, 12:05:38 AM »
Ok need some help I'm new to mach4..
When I go to z probe it doesn't go down I have
To get it about 1/16 above  for it can touch it
Maybe I'm doing something wrong ..and also if
I send it to cut it stays high above the surface...
Re: Auto tool zero...Z-probing
« Reply #1 on: March 03, 2019, 02:17:15 AM »
Hi,
we need more information before we can help. Probing is enacted by the motion controller, being realtime, under
Machs supervision.

What motion controller are you using?
Do you have it setup correctly, that is can you issue MDI commands like G0's and G1's?
Do you have the steps per unit value correctly programmed in each of the axes? That is if you command G0 X4,
does it travel exactly 4 inches.  I am assuming you are using inch units?
How are you probing, that is which button or Mach function are you using?
Have you tried to MDI a G31?

Craig
My wife left with my best friend...
     and I miss him!
Re: Auto tool zero...Z-probing
« Reply #2 on: March 03, 2019, 02:23:13 AM »
I have Ess smoothsteooer with bob MB2
And using mm..using the auto tool zero button
From mach4..yes I tried MDI
Re: Auto tool zero...Z-probing
« Reply #3 on: March 03, 2019, 02:43:04 AM »
Hi,
have you got the axes setup correctly ie the 'steps per unit' value?
Are you using inch units?
Which button or function, there are several.....perhaps a screen shot of it?
You tried MDIing what.....a G31?

Craig
My wife left with my best friend...
     and I miss him!
Re: Auto tool zero...Z-probing
« Reply #4 on: March 03, 2019, 02:47:47 AM »
Hi,
sorry, disregard:
Quote
Are you using inch units?
you did answer it in your reply.

Craig
My wife left with my best friend...
     and I miss him!
Re: Auto tool zero...Z-probing
« Reply #5 on: March 03, 2019, 08:10:26 AM »
Is it better to use inches..
Re: Auto tool zero...Z-probing
« Reply #6 on: March 03, 2019, 10:59:49 AM »
Hi,
no, it is strictly your preference.

Mach4 being a US product has preloaded parameters in inch units however they can be changed.
I use mm units and probe no problem.

Fill in some of the gaps....what touch/probe routine are you using?
Have you got the axes set u correctly?
What happens I you MDI a G31 move?

Craig
My wife left with my best friend...
     and I miss him!
Re: Auto tool zero...Z-probing
« Reply #7 on: March 03, 2019, 11:09:28 AM »
Did you mean the script...
Re: Auto tool zero...Z-probing
« Reply #8 on: March 03, 2019, 11:28:06 AM »
Hi,
yes the script......if that's what you are using or one of the buttons.

Craig
My wife left with my best friend...
     and I miss him!
Re: Auto tool zero...Z-probing
« Reply #9 on: March 03, 2019, 11:29:40 AM »
The button I'm using is the AUTO TOOL ZERO...