Hello Guest it is May 19, 2019, 03:26:11 AM

Author Topic: Spindle won't start  (Read 111 times)

0 Members and 1 Guest are viewing this topic.

Offline Herri

*
  •  19 19
    • View Profile
Spindle won't start
« on: March 02, 2019, 05:06:10 AM »
I’m running a Stepcraft 600 with Mach3. I had a proxxon spindle which was switched with a Stepcraft relay SWS1200.
I have now switched to a Kress 1050. The spindle now does not switch on and off as I run a work piece.
I have to manually switch the spindle on and off when the work is finished. (Plugged in to normal socket)

When I push the spindle button on Mach3 I hear a chick at the relay but the spindle does not run.

In the Ports & Pins window, if I change Step Low to ON the spindle runs but is still not switchable. (see photo)

Anyone, any ideas?

Many thanks
David

Offline reuelt

*
  •  444 444
    • View Profile
Re: Spindle won't start
« Reply #1 on: March 07, 2019, 07:29:07 AM »
The Kress 1050 is a 1050W AC "wood router" and NOT a "spindle".
You will need to add a BIGGER (>1050W) AC relay and do some AC rewiring to be able to switch on or off via software . Even then you will NOT be able to control the Kress router speed by software (MACH3)
Just do it manually.

Buy either
the DC Stepcraft HF500 with DC controller
or
a VFD drive with VFD Controller
so that Mach 3 or 4 can be configured to
turn on and set spindle speed
using M3 S********* (clockwise) or M4 S*********x (counterwise) and turn off using M5
"the gift of God is eternal life through Jesus Christ our Lord"

Offline Herri

*
  •  19 19
    • View Profile
Re: Spindle won't start
« Reply #2 on: March 07, 2019, 08:20:10 AM »
Thanks for the information. much appriciated :)