Hello Guest it is April 16, 2021, 05:29:12 PM

Author Topic: Cant jog incrementally or MPG at minimum step/unit (.0001)  (Read 398 times)

0 Members and 1 Guest are viewing this topic.

Cant jog incrementally or MPG at minimum step/unit (.0001)
« on: December 24, 2018, 11:33:46 AM »
I have dealt with this annoyance for a couple years now, but I need to find a solution.  My steps/unit is 10,000, so I should have a resolution of .0001.  Through MDI I can move in .0001 steps (G0 G91 Z-.0001) successfully.  I am not able to jog in mpg or incremental mode at .0001.  If I give the mpg wheel a spin it will move a few tenths, nothing predictable though.
My setup is MPG and jog buttons through Pokeys 56e, configured through Pokeys plugin for Mach4.  Motion is using a Hicon Integra 7766.  I don't know if this is a pokeys issue or Mach.
Thanks!

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Cant jog incrementally or MPG at minimum step/unit (.0001)
« Reply #1 on: December 28, 2018, 07:31:43 AM »
Just because the theoretical resolution is 0.0001 doesn't mean your machine can really move a true .0001.
How the axes will  move via jogging  and mpg use is defined in the plugin, thus , don't believe it is a Mach problem.

RICH
Re: Cant jog incrementally or MPG at minimum step/unit (.0001)
« Reply #2 on: December 28, 2018, 12:47:08 PM »
Years ago I have same problem. I cannot give you the ultimate right way, but tell how I get it to work.
 Mach4 setup "General" side. In the middle of side, chose "Jog increment" the one you can't get work.
Here I put 5 zero after 0.001  and enter.  (0.001000001) Restarted mach and Chose "Jogging" and
"Bottom jog mode", and then push Incremental jog at least 10 times and viola it works for me.
Hope it will solve your problem too.
Kindly Knud.