Hello Guest it is October 18, 2019, 10:37:36 AM

Author Topic: Mach3 plasma + THC 150 issue  (Read 630 times)

0 Members and 1 Guest are viewing this topic.

Mach3 plasma + THC 150 issue
« on: December 19, 2018, 06:49:18 AM »
Hi,

I have my DIY plasma with Mach3, Proma 150, floating head and Powermax45.
THC is connected to the raw voltage because I had problem when it was connected to divider (head is constantly go up and down).
Floating head, pierce high and cutting high works OK.

I have some problems.

1. After few seconds (not always) I get very short impulses from THC in down/up direction and then Z DRO change for example to +19mm but torch high is OK.

Re: Mach3 plasma + THC 150 issue
« Reply #1 on: December 19, 2018, 08:11:25 AM »
I posted without finished  ;D

2. When it finish cutting Z axis go to (for example) +9 mm and after that at home position it change to -40mm.
3. For what is this THC button?

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Mach3 plasma + THC 150 issue
« Reply #2 on: December 19, 2018, 01:45:52 PM »
there is a Little bit of Information in the mach Manual.
maybe it help's.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 plasma + THC 150 issue
« Reply #3 on: December 20, 2018, 02:29:25 AM »
Thanks TPS. This is helpful. But most problem is first two problems.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Mach3 plasma + THC 150 issue
« Reply #4 on: December 20, 2018, 03:23:47 AM »
i do not have a Plasma with THC (maybe soon), so i am not realy able to help you.
maybe someone else can jump in.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 plasma + THC 150 issue
« Reply #5 on: December 20, 2018, 05:45:27 AM »
Today I found that THC send signal for UP or DOWN but Z axis doesn't move.
In test mode it is going up/down.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Mach3 plasma + THC 150 issue
« Reply #6 on: December 20, 2018, 06:25:52 AM »
is the THC ON Signal working?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Mach3 plasma + THC 150 issue
« Reply #7 on: December 20, 2018, 06:47:27 AM »
Yes, that is OK.
Re: Mach3 plasma + THC 150 issue
« Reply #8 on: December 26, 2018, 04:57:26 AM »
Have you read and setup the proma thc 150 according to the primary manual

There are a couple of settings within the primary that inhibit motion until the arc voltage has stabilised and also another that activates a delay to allow the voltage to stabilise

http://proma-elektronika.com/index.php/en/products/thc-torch-height-control/compact-thc-150

The proma is a VERY basic thc it can also be a bit slow especially if you are cutting thin material fast

I did not get on well with the proma but what I did was the following to get it to work ok for me

YMMV

In the proma set the following up
HYS (hysteresis) set to +/- 1V (its as good as you can get and the error is 2v which is about 1.2mm (1/16") approximately!
d-t (delay time) set to ~ 2 seconds.   What this does is when the proma detects the cutting arc voltage window (below H-U...see below) it waits the time delay before issuing an THCUP or THCDN signal.... It allows for an extra amount of stability once the voltage is detected.
H-U (high voltage) this is the transfer voltage detection limit (aka ARCOK signal).... What I did was set this to a lower voltage but slightly above the cutting voltage of my machine which was 160v.... This allowed for the the arc transfer to take place within the machine and for the voltage to stabilise.   The knock on effect was that the pierce hole would be slightly larger because the machine will not begin motion until the arcok signal is received (providing you have ticked the box under config>>>ports and pins>>> spindle >>>thc )

As you have a powermax45 it gives you a arcok output indicating transfer has taken place so I would use that and ignore (not use) the arkok from the proma.
I would set the H-U on the primary to about 150v because this will act like a kerf detect THCDN inhibit.  I would also consider playing around with d-t setting in the proma because if you do use the arcok from the hypertherm45 motion will begin when the hypertherm45 gives the arcok signal but the primary will not give the thcup/thcdn signals until both the detected voltage is below H-U AND d-t has elapsed.  So if you are cutting some thin material at 400ipm in 2 sec it would have travelled 12" (ish {depends on your acceleration settings as motion will go from zero to your cutting voltage)

The proma IS a very low cost THC do not expect brilliant TH control. THC offered by some other manufacturers offer a lot of other options.  Mach3 is now also very old plasma technology and many more plasma options are available so again don't expect brilliant finish...  It's like cars... Newer models offer developments in performace, efficency, and automation that you won't get from an older model that's development has stagnated and has not been updated for many years)

Good luck
Rob

Albert Einstein ― “If you can't explain it to a six year old, you don't understand it yourself.”
Re: Mach3 plasma + THC 150 issue
« Reply #9 on: December 27, 2018, 07:53:17 AM »
Hi Rob,

thanks for your suggestions. In meantime I made it to work. Now I have only one problem.
Head going in pierce height, and after that into material and when THC start to give signal up/down, it going in correct height.
I am using MP1000-THC post processor. In SheetCam, cutting height is set to 1.5 mm.

What THC do you suggest?