Hello Guest it is December 16, 2019, 04:39:52 AM

Author Topic: Mach4 bore probing.  (Read 603 times)

0 Members and 1 Guest are viewing this topic.

Mach4 bore probing.
« on: December 18, 2018, 06:29:01 AM »
Hello. I made a big mistake, and looking for your help to solve it.
So we had this diy chc machine made about a year or so ago. Wiring and controller was done by myself and that was my third cnc conversion. I don`t have much knowledge about all this, but the machine was working fine all the time, until i did software updates without doing backups. I know, silly. Anyway, after updates when doing bore probing, it just not going it correctly. Attaching youtube links to the probing videos below, and also log file. Tried to speak to machsupport, they kept asking a lot of questions and only suggestion was to contact controller manufacturer as "error shows that is their error". The controllers manufacturer is not responding at all. Today i took another laptop with Mach4 and another controller to replace existing, it is doing absolutely same thing. Tried two different versions, all the same. But apparently probing script on both Mach4 versions are the same. So really i am out of ideas, how to get this machine back up and running. Any idea or suggestion is much appreciated. Thank you.

Hardware used:

windows 10 laptop x 2
Step/dir servos on all axis
simple touch probe

Software tested:

CSMIO plugin V3

Youtube links:


log file:

Re: Mach4 bore probing.
« Reply #1 on: December 18, 2018, 05:11:35 PM »
Something seems to go wrong here following a G1 move:

2018-12-06 16:23:03.908 - Signal id 161, (Probe), changed from HIGH to LOW.
2018-12-06 16:23:07.498 - Signal id 161, (Probe), changed from LOW to HIGH.

The probe signal is cleared and then set again. This causes the following probing operation to be aborted and the system to be disabled.


Re: Mach4 bore probing.
« Reply #2 on: December 19, 2018, 03:18:33 AM »
I see what you mean, but that iis probably caused by last probing steps being done in far right corner. Just crashing in side of the object being measured.
Re: Mach4 bore probing.
« Reply #3 on: December 19, 2018, 07:16:47 AM »
Here is a summary of your log file:

Nominal bore diameter 85

probe Y to 13.6
move to -29.8
Probe Y to -73.3
move to 3.1 (but nominal centre is -30)

Probe X to 23.0
backoff to -22.97
Probe X to 23.0 (still at 500 for slow rate)
Move to -20.5
Probe X to -64.0
Backoff to -3.7
Probe X to -64
Move to -6.3 (but nominal centre is -21)

Probe hits side as X and Y are way off centre.

I cannot make any sense of these figures. The probe does not find the centre of the hole, but ends way off to one corner, causing the unwanted strike. Also your backoff distance and slow speed don't seem to be properly set. . I know the original probing module contained errors, but cannot remember if these affected the bore routine. I can say that using my corrected probing module and CSMIO plugin 3.16 the bore routine works perfectly, so I do not bleive this to be a CSMIO issue unless you are using an old plugin. Be sure to use the latest 3.16. If you already have this, I would check over the LUA code within the bore routine, as it seems likely to contain errors.

Re: Mach4 bore probing.
« Reply #4 on: December 20, 2018, 03:06:54 AM »
So what to do now? I have no clue about lua scripting, also i wonder, is that probing script the same across all of the versions? As i tried oldest version, newest version and random version of Mach4 from their ftp server. What is the solution?
Re: Mach4 bore probing.
« Reply #5 on: December 20, 2018, 05:21:59 AM »
The probing module has not been changed in recent times. I had a quick eyeball over the Bore script last night and nothing untoward jumps out at me.

So are you using plugin 3.16?In terms of Mach4, I tend to use one of the development versions. I am currently using 3882. My controller is the IP-A, and I cannot say if there are subtle differences in the plugin for the IP-M.

I am tending to think that the plugin is returning the wrong positions, as neither the backoff position nor the centre are coming out sensibly. Presumeably you have set backoff to a small value, e.g. 0.3mm, yet your probe is backing off some 45mm, which makes no sense.

Ultimately, you may need to add messages to the probing script to see just what values are being returned by the probe, but before that, have you tried a simpler probing operation, such as probing the X position of a part at a known position. Does this give a credible result?

You'd do well to start reading up on LUA scripting.

Re: Mach4 bore probing.
« Reply #6 on: December 22, 2018, 11:51:07 AM »
Had a bit of spare time today so fired up the mill and re-configured it to use the standard Mach4Mill WX4 screen set and standard probing module. Mach4 v3882, CSMIO-IP/A with plugin 3.16, probing module dated July 2017.

I set probe 0 to use G31.0, fast feed 500mm/min, slow feed 10mm/min, overshoot 2mm, backoff 0.25mm.

I used the Bore function to probe a 24mm i.d.  rin and also performed both offset and radius calibrations using the same ring. All worked perfectly, so what you are  getting wrong I don't know.

Re: Mach4 bore probing.
« Reply #7 on: March 07, 2019, 10:56:43 AM »
Reply from cs-lab: 

 we know this issue and it will be solved soon.

There was some small change done in Mach4 and we have to adjust the plugin to it. Please wait.
Re: Mach4 bore probing.
« Reply #8 on: March 16, 2019, 08:01:53 AM »
Interesting, but I'm not holding my breath for it.

I am currently using build 4109 of Mach4 with the IP/A and plugin 3.16 and have used probing extensively without any problems. I wonder if the issue affects only the step/direction versions of the controller? Otherwise, could it be specific to Win10 (I use Win7 32 bit)?

Re: Mach4 bore probing.
« Reply #9 on: March 17, 2019, 07:58:04 AM »
Hi guys,
once upon a time CSLabs had a market leading reputation for support and fixed bugs and added features to
their Mach3 plugin in short order.

Their Mach4 plugin was very slow to arrive and have seen posts where CSMIO/a and CSMIO/m owners report bugs
and months pass without the Mach4 plugin being fixed. Has the situation improved at all?

There seems no doubt about the quality of the hardware but firmware support seems sadly lacking.

My wife left with my best friend...
     and I miss him!