Hello Guest it is May 16, 2021, 02:52:53 PM

Author Topic: jogging increments.  (Read 535 times)

0 Members and 1 Guest are viewing this topic.

jogging increments.
« on: December 15, 2018, 05:13:52 PM »
I have my machine newly configured in metric. Status codes at bottom say that G21 is enabled. However, when I jog 0.1000 both machine and DRO move 2.54mm, 0.1". Could anybody tell me how to change the units on the jog screen as they appear to be outputting in imperial although metric is set in the configuration?

Re: jogging increments.
« Reply #1 on: December 15, 2018, 06:37:23 PM »
Hi,
the jog increments are in machine setup units.
I assume therefore that your machine is set up in inches. Sorry can't tell you hat the difference is between 'machine setup units'
and 'units mode'. Note that my machine is setup in metric and I have made them consistent.

The biggest jog increment programmed into my machine is 1 (mm). If I code a G20, ie displaying inch mode, my DROs do indeed display
inches but they increment 0.039 inch per max jog step.

Craig
My wife left with my best friend...
     and I miss him!
Re: jogging increments.
« Reply #2 on: December 16, 2018, 04:01:07 AM »
There is a bug in some older builds of Mach 4 that will change the jogging to inches after changing configuration settings.  The way around this is to enable after completing the configuration and pressing the reset button.  This appears to be fixed in at least build 3882 and later builds.

Edit: According to the change log it appears to have been fixed somewhere in builds 3806 - 3858.
« Last Edit: December 16, 2018, 04:07:04 AM by RBeaubien »
- Robert Beaubien
- Drone Plastics
-
“Dear Algebra, Please stop asking us to find your X.  She's never coming back and don't ask Y.”
Re: jogging increments.
« Reply #3 on: December 16, 2018, 04:10:17 AM »
I have fixed it! After reading joeaverages reply, I looked at the configuration and I was correctly set to mm on both machine setup units and units mode so I decided to set both to inches and recycle the program. Jogging corrected operated in inches mode. I then reset to mm on both and restarted Mach4 and lo and behold it is now correctly jogging in mm! I don't know what caused this as it was a clean install of the latest download. Thanks for the pointers.
Re: jogging increments.
« Reply #4 on: December 16, 2018, 04:17:34 AM »
Hi,
some changes that you make in either the Control plugin and/or your motion plugin are effective immediately where others
require the .ini file to be updated and then re-read by Mach before becoming effective. That means either Mach shutdown
and then restart or a 'Flush' command that flushes updated data to the .ini file.

Smurph did explain the difference on an occasion some while ago....I can't find the post at the moment.

Craig
My wife left with my best friend...
     and I miss him!