Hello Guest it is June 17, 2021, 04:20:18 AM

Author Topic: Z-axis setup  (Read 555 times)

0 Members and 1 Guest are viewing this topic.

Z-axis setup
« on: December 06, 2018, 06:51:04 PM »
Hi.  I've had to re-install Mach3 after an electrical storm crashed my PC.  I've got a problem with My z-axis - it is jogging OK, but after zeroing and jogging up, when I press "Go to zero" it heads in the wrong direction.  I've checked the step pin and dir pin settings, and reversing the dir low active just makes it jog in the wrong direction.  The native units are imperial, but I've re-zeroed after loading the metric g-code (which starts with the G21 input).  Where to from here?  My machine is a RomaxxCNC HS-1 - I've installed the XML provided by the manufacturer.  The settings and g-code ran fine previously.
Re: Z-axis setup
« Reply #1 on: December 09, 2018, 03:51:35 PM »
I'm no expert, but I've had a similar experience before. It was a stuck plunger on the limit switch. You might try manually wiggling the plungers on all of your limit switches. Or just Open the diagnostics screen (TAB key) and see if any of the LED's are lit up on any of the axis limits. Hope this helps. I know the frustration!
Re: Z-axis setup
« Reply #2 on: December 10, 2018, 02:58:04 PM »
Thanks for the suggestion.  Actually this is a pretty basic small machine and it doesn't have limit switches - it is quite capable running into the physical stops which isn't good for it.  I've figured that the machine is actually heading for the machine zero rather than the job zero.  It seems to run fine on jobs so I'm ignoring the problem at the moment and just not using the "go to zero" command, which previously I found really useful.
Re: Z-axis setup
« Reply #3 on: December 11, 2018, 06:02:28 AM »
Try config, ports and pins, mill options. Then check the box that says homed true without home switches.


HTH

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.