Hello Guest it is December 10, 2019, 01:14:43 PM

Author Topic: Couple of itchy problems can someone please help.  (Read 175 times)

0 Members and 1 Guest are viewing this topic.

Couple of itchy problems can someone please help.
« on: November 02, 2018, 02:41:25 AM »
Home built CNC Router.

I use it in my door making joinery business. Man. I dont know how I got by without it! Ok. I am using the 2010 screenset Gerry built. Two problems:

1. When I probe for an edge, and I do it lots so I can set my machine perfectly on the side of a work piece. I just use the end mill I am using at the time, and probe it against the moveable plate that I use for auto depth. Obviously I make sure I put the diameter of the milling bit into the program. So no probe but it works great. The problem is, that if I do an edge probe, it sets all my machine coordinates to zero, not just the coordinates. So this corresponding action throws out all my limits etc requiring a homing to get my limits working again. I just want it to zero on the edge, not everything.

2. One operation I do, is I physically rotate my spindle 45 deg. This is so I can mortise into the edge of a door. Great for installing a lock and rebate set. I do this by just swapping the pins/outputs for the Z and the X inside the program. It works great. But, if I try to save this XML file and rename it, the probing, and the auto depth setting no longer works. I just cant work out what I am supposed to do. All I want is a "router" profile, and a "side router" profile that I can load on the program start. I have even tried just copying the file and renaming. Currently I am having to swap out the software pins each time.

Small things. Please help. I am not saying I have spent hours trying to work this out. Just, you know, if someone knew what to do here???

Boydage