Hello Guest it is May 29, 2023, 05:54:34 PM

Author Topic: Feed Rate is too slow when interpolating  (Read 980 times)

0 Members and 1 Guest are viewing this topic.

Feed Rate is too slow when interpolating
« on: October 15, 2018, 04:45:30 PM »

I have a quick question. If I'm machining something that uses simple commands (circle, line, arc) I can hit my specified feed rate no problem of course in these scenarios, mach is feeding data to the controller a lot slower. My machine currently runs 4000mm/min on the X and Y axis travel.

However if I run an adaptive strategy for a toolpath, where it is constantly outputting (X,Y) coordinates to interpolate a circle, my feedrates are limited to about 700-1000mm, and it varies, increasing as the radius of the circle increases but it stalls out around 1000mm/min and refuses to go any faster.

My question is simple, what is causing this? I don't know if it's an acceleration limitation, or perhaps my old windows XP machine with 1Gb or ram can't keep up?

I appreciate any insight!

Offline ger21

  • *
  •  6,295 6,295
    • View Profile
    • The CNC Woodworker
Re: Feed Rate is too slow when interpolating
« Reply #1 on: October 15, 2018, 05:38:51 PM »
Mostly acceleration.

CV mode can play a part, but adjusting CV settings to get more speed will likely  result in deviation from thje path.

2010 Screenset

JointCAM Dovetail and Box Joint software
Re: Feed Rate is too slow when interpolating
« Reply #2 on: October 15, 2018, 07:43:27 PM »

I just did a test, and if I execute a simple circle command, it moves at full speed on a 1in circle. But if I do the x-y interpolation, it's slower. So it is capable of hitting the values from acceleration it seems if it's just doing a simple circle or line.

I bet you're right about the CV settting stuff. But I am hesitant to modify that and mess up the accuracy as you mention.
Re: Feed Rate is too slow when interpolating
« Reply #3 on: October 23, 2018, 05:44:59 AM »
Hi Patrick,
For clarities sake, cutting a circle with an X,Y machine, is interpolation.
If your G-code has lots of little lines of code, as when using an adaptive strategy, make sure you are running G64, not G61. G61 is exact stop mode and will slow you way down. G64 is constant velocity mode and will try to go through the code faster. Small  segment code can be limited by the computers speed to process all the lines of code in a timely fashion.
You can also take a look at what your look ahead is set to. IIRC it should be ~200 in Mach3. This will make processing the small segment code as fast as possible.

You could also try posting the offending code here and see if someone can run it on their machine.


We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.