Hello Guest it is October 19, 2021, 07:00:01 PM

Author Topic: ActivateSignal  (Read 615 times)

0 Members and 1 Guest are viewing this topic.

ActivateSignal
« on: October 08, 2018, 08:02:09 PM »
Since this is my first post here, Hello to everyone.

As the title implies I would like to switch a relay using the ActivateSignal command.

I can switch the relay by clicking the active low button in the output tab. So the wiring seems to be ok.

So far I didn’t manage to switch the output by using the ActivateSignal command.

I setup Output #1 on Port 1 Pin 8

As far as I understood the code should be

ActivateSignal(OUTPUT1)

I put this in a M999 script and called it via MDI. The relay doesn’t move, but the Stepper Motors move a bit each time I call the M999.

What is going on here?
Re: ActivateSignal
« Reply #1 on: October 09, 2018, 06:22:24 AM »
Solved: Turned out to be a week power supply on 12v.
Strange though that it worked in the Output Tab but not with the ActivateSignal command.
Anyway, with a separate power supply for the relay it works also with the script command now.

Offline Tweakie.CNC

*
  • *
  •  8,833 8,833
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: ActivateSignal
« Reply #2 on: October 09, 2018, 06:41:10 AM »
 :)

Pleased you found the problem.
KEEP SAFE !