Hello Guest it is June 27, 2019, 01:37:06 AM

Author Topic: Help with acceleration and speed settings  (Read 4281 times)

0 Members and 1 Guest are viewing this topic.

Help with acceleration and speed settings
« on: July 31, 2007, 11:04:26 PM »
I am just finishing the rebuild of my cnc router.  It started out with small Nema 23 steppers and very light gantry.  The only thing I kept was the very solidly built table.  It now is much heavier and powered with Nema 34 1289 oz/in steppers.
I now need to know the best and safest way to figure out my maximum acceleration and speeds for all the axis as well as a good starting point. If anyone could help it would be greatly appreciated.
Here is some information:
The x gantry including y carriage and z weighs 295 lbs. and is moved with 2- 1289 oz/in steppers.
The y carriage including the z weighs 95 lbs. and is moved with 1- 1289 oz/in stepper.
The Z weighs 69 lbs. and is moved with 1- 1289 oz/in stepper.

Everything is rack and pinion using 20 tooth pinions and 20 pitch rack no gear reduction.
Using Gecko 201 drives.

Thanks

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Help with acceleration and speed settings
« Reply #1 on: August 01, 2007, 01:41:09 PM »
I dpnt think figure it out is the right phrase. You are talking about big, heavy peices of machinery.
I think your best approach is to start low and gradually work up to what you consider is a safe speed for the chunk of metal that is flying about.

I dont know what speeds you are expecting, so cannot really comment, but I would keep the acceleration low to start with, since it is this that will cause the problems, not necessarily the speed.

How long is the maximum travel.

Using the Mach3 stepper motor configuration, I would set the acceleration so the table reaches maximum speed half through the maximum travel (as per the graph on the syystem).  Keep increasing the speed until you reach what you consider the maximum safe speed, then gradually ramp up the acceleration to get you to maximum speed more quickly
Not me driving the engine - I'm better looking.

vmax549

*
Re: Help with acceleration and speed settings
« Reply #2 on: August 01, 2007, 02:10:26 PM »
The only other way I know of is too hook up an amp meter to the drives and keep tuning upward untill you have reached max amps for the motor during excellaration. That is about the best you can expect out of the drive/motor combo. Just remember what speeds up "MUST" slow down and the inertia in the moving mass can create problems slowing it down. So you have to also check the voltage level on max decellaration to make sure that you do not regenerate a voltage that exceeds the safe level for the drive. You will probable have to sacrifice a little excell to be safe on the decell side.

(;-) TP

Re: Help with acceleration and speed settings
« Reply #3 on: August 01, 2007, 07:07:48 PM »
Thanks for the answers.
The table size is  about 50" by 100".
I have another question.
Should I use the auto current reduction on the 201 drives or is it better not to use it?

Thanks

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Help with acceleration and speed settings
« Reply #4 on: August 02, 2007, 04:34:24 AM »
I don't know what the current reduction does on your 201's

On my boards I can reduce the current to STATIC motors to reduce current on the system generally when the motors are just stood, but this does not apply when they are moving.
Not me driving the engine - I'm better looking.

vmax549

*
Re: Help with acceleration and speed settings
« Reply #5 on: August 02, 2007, 10:04:25 AM »
I would use the current reduction for the reasons JIM has stated. It helps from adding heat to the servos from just standing still by reducing the holding current.(;-) TP

Offline DAlgie

*
  •  304 304
    • View Profile
    • Algie Composite Aircraft
Re: Help with acceleration and speed settings
« Reply #6 on: August 02, 2007, 08:20:13 PM »
I have a large gantry router, not controlled by mach though. It is fast, and the gantry is heavy. Don't have numbers for you here however. it uses about 600 oz/in steppers, driving a tooth belt reduction at a guess, 10:1 reduction, then this drives a 20 tooth pinion onto the rack. big difference to yours, but it also uses 90 volts, the motors got hot enough that I watercooled them. I run it over 100 hour jobs at 700 inches per min with no problems. Sounds like your motors need some gearing possibly.
                             Dave.