Hello Guest it is May 23, 2019, 07:38:36 PM

Author Topic: Macro in G-code pauses execution for 1 sec  (Read 266 times)

0 Members and 1 Guest are viewing this topic.

Macro in G-code pauses execution for 1 sec
« on: September 27, 2018, 02:26:28 AM »
Hello,

I have a problem with executing macros. Everything runs smoothly except when the code needs to run macro, for example M29, which just disables movement on axis A, it pauses just for 1 second and after that it continues normally.

I am using Mach3, Hicon integra board and Leadshine drivers.

I would like it to run without this 1 second pause. Where does the problem lies. What do I need to fix. Thank yiu for your answers.
« Last Edit: September 27, 2018, 02:28:40 AM by Foger »

Offline TPS

*
  •  1,253 1,253
    • View Profile
Re: Macro in G-code pauses execution for 1 sec
« Reply #1 on: September 27, 2018, 02:43:42 PM »
if you Show us your M29 macro, somebody will be able to help you.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Macro in G-code pauses execution for 1 sec
« Reply #2 on: September 27, 2018, 04:05:20 PM »
I just gave example. Macro M29 can even be empty with 0 code in it and when G-code reaches the point to call macro it waits for about 1 second and then continue normaly. I would just like to see CNC work with some constant speed without stops.

I found out that the problem probably lies in Hicon Integra  board, because i tried and run the same code on other CNC which has a board from leafboy77 and the code runed smoothly without any stops when it hit the macro.

Maybe I should change some settings for Hicon board to run macros more smooth?

Offline TPS

*
  •  1,253 1,253
    • View Profile
Re: Macro in G-code pauses execution for 1 sec
« Reply #3 on: September 28, 2018, 02:03:36 AM »
or contact vital Systems customer Support?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.