Hello Guest it is April 22, 2021, 02:27:37 PM

Author Topic: Setting up Touch plate in Mach4? Touch UI? Probe tab?  (Read 1313 times)

0 Members and 1 Guest are viewing this topic.

Setting up Touch plate in Mach4? Touch UI? Probe tab?
« on: September 22, 2018, 07:03:22 AM »
I'm trying to setup my touch plate with Mach4 + ESS (Ethernet smoothstepper) + KK01 breakout board, but am struggling to trigger any touch indication within Mach4.

I've done the following:
Step 1 > Wired up touch plate with GND+Port2 Pin10 on the breakout board
Step 2 > Mach4 > Plugins > ESS > Pins Signal > Configured the probe
Step 3 > Mach4 > Controls > Input signals > Configured the probe

On the "Machine diagnostics" tab I now have a active green probe indication.

Doing (a manual) touch down on the touch plate, I don't see the probe indicator do anything.

What am I missing?

Other semi-related questions:
1. I understand there's a "probe" tab in Mach4 - on a default installation I however don't see it. How do I enable the "probe" tab?
2. I understand there's a so called "Touch UI" - same as question 1, how do I enable that?







Re: Setting up Touch plate in Mach4? Touch UI? Probe tab?
« Reply #1 on: September 22, 2018, 11:51:15 AM »
Just gonna answer my question 1+2:

The probe + Touch UI (tab/button) can be enabled by loading the correct view for this.

I was using the "wxMach" view where these things don't appear pr. default, but could make it appear by doing the following:

> Go to: View > Load screen > choose wx4.set

Still figuring out how to trigger anything on touch
Re: Setting up Touch plate in Mach4? Touch UI? Probe tab?
« Reply #2 on: September 22, 2018, 02:23:07 PM »
Got it to work! Or atleast I think so.

First of all: Im a big rookie, so I had wrongly setup my pin config to: Port2-Pin10
- Whereas the correct setup is: Port1-Pin10

I became aware of this when looking at > Diagnostics > ESS
- Here I could see that touching the plate would trigger "Port 1 Inputs - 10"

From the Touch UI I can now run the "Find Z" command and upon touch, Z movement stops and retracts.

In the Mach4 history I do get a Lua error - not sure if it's anything serious? (only tried touch action in wiring phase)
Quote
Z axis is performing a touch move.
ESS: Successful Probe0 Strike. Probing finished.
Z Axis Offset Set to: -0.69.
Retracting
Touch is finished. Z axis set to -0.69
Lua: Error while running chunk
C:\Mach4Hobby/Modules/mcTouchOff.lua:1178: attempt to compare nil with number
stack traceback:
   C:\Mach4Hobby/Modules/mcTouchOff.lua:1178: in function 'frameMainOnUpdateUI'
   C:\Mach4Hobby/Modules/mcTouchOff.lua:912: in function <C:\Mach4Hobby/Modules/mcTouchOff.lua:911>
Re: Setting up Touch plate in Mach4? Touch UI? Probe tab?
« Reply #3 on: March 07, 2021, 06:36:45 PM »
I know I am replying to an old topic but I am starting the same adventure with the same hardware and I can not find any straightforward documentation to get this done.  So....did you figure this out and get it to work?  Can you share/document the process?