Hello Guest it is May 22, 2019, 09:33:38 PM

Author Topic: Spindle On/Off causing Pokeys disconnection  (Read 192 times)

0 Members and 1 Guest are viewing this topic.

Spindle On/Off causing Pokeys disconnection
« on: September 21, 2018, 06:23:57 PM »
Hi there, new to the forum. And to Mach3. And to CNC. Basically pretty green all around.

I'm in the process of getting a new hobbyist CNC up and running, and I just got the spindle on and the VFD configured for Mach3 on/off control. It's all driven by the Pokeys57CNC board.

Today I've found that if I turn the spindle on and off with F5, it will eventually lose connection with the PoKeys and maintain whatever state it was last in (ie spindle on, even an X/Y/Z move if in progress while it disconnects, leading to a crash). There's no indication in Mach3 that it's lost communication with the board, but it almost definitely has. I've checked the Diagnostic page, and I can activate the limit switches all day and nothing lights up. And of course no jogging or program runs. The only way to reset this is to restart Mach3, but happens again almost as soon as I use spindle on/off.

It's unclear if this is a Mach3 issue, or a PoKeys board issue, but it's a show-stopper nonetheless. Any insight or solutions anyone might have would be greatly appreciated.

Thanks! - Ian
Re: Spindle On/Off causing Pokeys disconnection
« Reply #1 on: September 21, 2018, 06:43:53 PM »
Hi,
sounds more likely to me that the spindle is causing noise at switch on/switch off.

Can you power the spindle from a preferably remote power socket from the PC/machine?
It is possible that the power surge that occurrs within the spindle is being conducted/transfered
to your controller.

Craig
My wife left with my best friend...
     and I miss him!