Hello Guest it is November 28, 2021, 01:06:27 AM

Author Topic: DRO,s scaling error  (Read 739 times)

0 Members and 1 Guest are viewing this topic.

DRO,s scaling error
« on: August 28, 2018, 12:55:48 AM »
Hello everyone, I'm new to the board and to mach4. I built a cnc plasma cutter controlled thru mach4 and a pmdx-424 smartbob. I have the machine setup units and the units mode set to mm. The problem I'm having is that when I jog any axis in incremental mode with the increment set to 1 the axis moves 1 mm but the dro shows it moved 25.4. Am I missing a scaling factor somewhere? Any help will be appreciated.
Re: DRO,s scaling error
« Reply #1 on: August 28, 2018, 08:05:13 AM »
Hi,
welcome......you poor sick little puppy! ::)

I have not seen that problem myself but there have been some posts about it. The last time it was discussed smurph, one of the Mach4 gurus
has been alerted to the problem and was anticipating a fix for it.

If I'm not mistaken it does not happen all the time but as a result of a specific sequence of events. Does that fit your description?
I'll try to find the thread and link you to it.

Craig
My wife left with my best friend...
     and I miss him!
Re: DRO,s scaling error
« Reply #2 on: August 29, 2018, 12:37:40 AM »
Thanks for the reply
I found that if I restart mach4 the dro's work properly but the axis travel is only about .04mm. If I go to the motor configuration screen my settings are the same. When I exit the screen the axis then jogs 1mm when I jog it incrementally but the dro shows 25.4mm. My steppers are 200 steps per revolution and my ballscrews are 5mm pitch. That should be 40 steps for 1mm of travel. I found that if I set the steps per unit to 960 then restart mach4 the incremental jog will move the axis close to 1mm but not exactly.

Offline smurph

*
  • *
  •  1,475 1,475
  • "That there... that's an RV."
    • View Profile
Re: DRO,s scaling error
« Reply #3 on: September 12, 2018, 01:33:47 AM »
What build are you running?  Try the latest from the website. 

Steve