Hello Guest it is September 21, 2021, 06:38:10 AM

Author Topic: Tool Path Window Blank  (Read 1024 times)

0 Members and 1 Guest are viewing this topic.

Tool Path Window Blank
« on: August 11, 2018, 10:55:52 AM »
Hi All,

As you can see from the Screen shot, the main Tool Path Window is blank, but the Tool Path Ops window is displaying as it should (It's in Demo mode untill I sort this issue out).
I've uninstalled and re installed several times and various builds, but thay all now behave the same, even though at one time (Before I tried the latest build I think) Mach 4 was working as expected.
Could well be a Win10 update that has caused the problem and will not affect the computer that I use to run my machine, because It's not connected to the net, but I would like Mach 4 to run on this computer as it used to.
Any Ideas?

Nick.


« Last Edit: August 11, 2018, 11:00:34 AM by nick952 »
Re: Tool Path Window Blank
« Reply #1 on: August 11, 2018, 02:32:51 PM »
Hi,
odd....in Screen Edit mode check that the main tooplath window is enabled.

You could also check the settings of the little toolpath window that is still operating and ensure that the main toolpath window
has the same settings.

Craig
My wife left with my best friend...
     and I miss him!
Re: Tool Path Window Blank
« Reply #2 on: August 13, 2018, 05:21:32 AM »
Hi Craig,

Yep, already checked that for all the toolpath windows (On the Program Run, Tool Path and Machine Diagnostic windows)  and they are all enabled. Apart from the size and position,the only other difference was the Enabled States, so I made them all the same (All), but this made no change and the only one that displays as it should is the "Tool Path ops" .
More info that may help is if I change the Bg Colour in Screen Edit mode, the new colour is applied whilst still in Edit Mode, but when I save the change and exit Screen Edit, the new colour is not applied!

Nick.
Re: Tool Path Window Blank
« Reply #3 on: August 13, 2018, 05:58:02 AM »
Hi,
I'm still no closer to the answer but:

Quote
More info that may help is if I change the Bg Colour in Screen Edit mode, the new colour is applied whilst still in Edit Mode, but when I save the change and exit Screen Edit, the new colour is not applied!

Note that in the pic I attached the window has a background colour of silver. But when I exit Edit mode the window turns to regular blue. Thus the colour settings made
in Machs Toolpath tab overwrite the background colour. Its not that Mach has ignored a setting but in use that setting is overwritten, its not what I'd call a fault and I don't
think is going to give us a great deal of insight into your problem.

Craig
My wife left with my best friend...
     and I miss him!
Re: Tool Path Window Blank
« Reply #4 on: August 27, 2018, 12:04:52 PM »
Just to close this off.

Now working fine, without any intervention from me, so probably a windows update that both caused and fixed the problem.

Nick.