Hello Guest it is July 17, 2019, 09:44:45 AM

Author Topic: No movement all 3 axix's  (Read 828 times)

0 Members and 1 Guest are viewing this topic.

Re: No movement all 3 axix's
« Reply #10 on: August 12, 2018, 12:15:11 PM »
I used the same computer 6 months ago and now when I try open MACH3 it shuts the computer down, I have uninstalled and reinstalled MACH 3 and still shuts down. All my other applications work on the computer just MACH 3 is the issue. I was told to uninstall some new updates and still having the same issues, any suggestions?
Re: No movement all 3 axix's
« Reply #11 on: August 12, 2018, 02:38:13 PM »
Hi,
there are still one or more updates on your PC which are causing that. If you cant remove them you may have to do
a Restore to a point where it still worked. Thereafter you will have to disable Windows updates or keep the PC off the net.

This problem affects the parallel port. You might want to consider an external motion controller like a SmoothStepper which
are unaffected.

Craig
My wife left with my best friend...
     and I miss him!
Re: No movement all 3 axix's
« Reply #12 on: August 12, 2018, 02:54:58 PM »
Yes i have a mulit meter
Re: No movement all 3 axix's
« Reply #13 on: August 12, 2018, 03:00:27 PM »
Hi,
then measure the voltage between the X Dir pin, looks to be pin 2 or 3 and earth with an X move in one direction and then
again but with the X axis moving in the other direction.

It might be 0, or thereabout one way and 5V , or thereabout the other way.

Craig
My wife left with my best friend...
     and I miss him!
Re: No movement all 3 axix's
« Reply #14 on: August 12, 2018, 06:07:16 PM »
The direction goes from 56.5 mv in one direction to 3.31 v in the other.

The spec on the 251X says the direction and step  can be driven with 3.3V or 5V logic inly input current will change from -1ma to -.67ma for login "O"

I really want to thank you for help on this problem.
Re: No movement all 3 axix's
« Reply #15 on: August 12, 2018, 07:08:19 PM »
Hi,
OK it sounds increasingly like the drivers. Do they have an enable input? If they do it it active?

Craig
My wife left with my best friend...
     and I miss him!
Re: No movement all 3 axix's
« Reply #16 on: August 12, 2018, 08:33:50 PM »
Craig --  I got it - it works your suggestion to check the level of the direction pin Got me in the ballpark to find the problem. To make a long story short the step and direction pins in the configuration did not match the wiring. This is why if I plugged the parallel cable from one CNC to the other one worked and one did not, gave you the impression that the config and software were correct. The fact that we did not have the correct files that went with the machine when it was built caused all the problems.

MANY THANKS FOR YOUR HELP
Re: No movement all 3 axix's
« Reply #17 on: August 12, 2018, 08:43:42 PM »
Hi,
kool, glad you got it sorted. Of course that means that Steve Stallings called it right a while back!

Craig
My wife left with my best friend...
     and I miss him!
Re: No movement all 3 axix's
« Reply #18 on: August 12, 2018, 08:50:23 PM »
I had my head in a very dark place